summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-08-27 14:55:46 -0400
committerLudovic Courtès <ludo@gnu.org>2022-09-04 23:10:11 +0200
commit5142fba364a991fdb797208275d760033d09199b (patch)
tree16cda435fad552cbcb2b12186cc1d163dcb81f6b /gnu/packages/chez.scm
parent911768b6d5f4f1a3df58f025b4b07d63c8e729a8 (diff)
downloadguix-patches-5142fba364a991fdb797208275d760033d09199b.tar
guix-patches-5142fba364a991fdb797208275d760033d09199b.tar.gz
gnu: chez-scheme: Fix use of "/bin/sh".
The unsuccessful attempt to execute "/bin/sh" by Chez Scheme's 'process' function seems to have caused parts of the Chez Scheme test suite to have been silently skipped. The issue was exposed by the upcoming changes to Racket's build system. * gnu/packages/patches/chez-scheme-bin-sh.patch, gnu/packages/patches/racket-chez-scheme-bin-sh.patch: New patches. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/racket.scm (%racket-origin)[patches]: Update accordingly. * gnu/packages/chez.scm (chez-scheme)[origin]<patches>: Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 812d41fc5b..c627c4d842 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -269,6 +269,7 @@ Otherwise, SYSTEM can use only the ``portable bytecode'' backends."
(base32
"0xchqq8cm0ka5wgpn18sjs0hh15rc3nb7xrjqbbc9al3asq0d7gc"))
(file-name (git-file-name name version))
+ (patches (search-patches "chez-scheme-bin-sh.patch"))
(snippet #~(begin
(use-modules (guix build utils))
;; TODO: consider putting this in a (guix ...) or