summaryrefslogtreecommitdiff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-01-28 23:02:02 +0000
committerChristopher Baines <mail@cbaines.net>2024-02-13 11:04:48 +0000
commite5bfc462dd695a570fe88c4c6d6efee808fd1a56 (patch)
treee00c1da060b3b0281060b6eb51e7f9ddde03a355 /gnu/packages/chemistry.scm
parentcc772e7f3172a8014e32c7ea3f6626963d4e9e16 (diff)
downloadguix-patches-e5bfc462dd695a570fe88c4c6d6efee808fd1a56.tar
guix-patches-e5bfc462dd695a570fe88c4c6d6efee808fd1a56.tar.gz
gnu: rdkit: Update to 2023.09.4.
* gnu/packages/chemistry.scm (rdkit): Update to 2023.09.4. [arguments]: Skip testConrec test in check phase. [native-inputs]: Replace catch2 with catch2-3. * gnu/packages/patches/rdkit-unbundle-external-dependencies.patch: Adjust patch. [supported-systems]: New field. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 98141737ac..bd27bfad7a 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -1073,7 +1073,7 @@ other ring topology descriptions.")
(define-public rdkit
(package
(name "rdkit")
- (version "2022.03.5")
+ (version "2023.09.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1084,7 +1084,7 @@ other ring topology descriptions.")
(file-name (git-file-name name version))
(sha256
(base32
- "19idgilabh04cbr1qj6zgrgsfjm248mmfz6fsr0smrd68d0xnml9"))
+ "1lgcgijlzzwpfxndsdlx13npdfk7hcii11zg25cvpmzhbpn6vyn8"))
(patches
(search-patches "rdkit-unbundle-external-dependencies.patch"))
(modules '((guix build utils)))
@@ -1183,7 +1183,10 @@ other ring topology descriptions.")
"substructLibraryTest" "pyFeatures"
"pythonTestDirML" "pythonTestDirChem"
;; Catching Python exception fails
- "pyRanker") "|")
+ "pyRanker"
+ ;; Flaky test depending on floating point rounding
+ "testConrec"
+ ) "|")
")")))))))))
(inputs
(list avalon-toolkit
@@ -1200,7 +1203,7 @@ other ring topology descriptions.")
(native-inputs
(list bison
boost
- catch2
+ catch2-3
eigen
flex
freesasa
@@ -1214,4 +1217,8 @@ other ring topology descriptions.")
(description "RDKit is a C++ and Python library for cheminformatics, which
includes (among other things) the analysis and modification of molecules in 2D
and 3D and descriptor generation for machine learning.")
+ ;; For 32 bit systems, there is a bug in Boost.Python:
+ ;; https://github.com/boostorg/python/issues/312. Additionally, several
+ ;; other test fail.
+ (supported-systems %64bit-supported-systems)
(license license:bsd-3)))