summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-01-13 17:20:55 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2024-01-13 17:29:46 -0500
commit18393fcdddf5c3d834fa89ebf5f3925fc5b166ed (patch)
treed7b75b29104baa4036df6752b89f2bd8e2a2f59c /gnu/packages/check.scm
parent31e736dac29e6f0ff8a2de3f28e210a68684ad21 (diff)
downloadguix-patches-18393fcdddf5c3d834fa89ebf5f3925fc5b166ed.tar
guix-patches-18393fcdddf5c3d834fa89ebf5f3925fc5b166ed.tar.gz
gnu: check2: Fix tests on i686-linux.
Reported upstream to <https://github.com/catchorg/Catch2/issues/2796>. It is expected that SSE2 is enabled for i686 builds or tests fail. * gnu/packages/check.scm (check2)[arguments]: Enable SSE2 for x86_64-linux and i686-linux in configure-flags. Co-authored-by: Richard Sent <richard@freakingpenguin.com> Co-authored-by: Jo Gay <@jane.lx.gay> Change-Id: I99205f92b66ab3d10affbfb58918f37069ba82ec
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 449340f331..b475aea8ae 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -108,6 +108,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix deprecation)
+ #:use-module (ice-9 match)
#:use-module (srfi srfi-1))
(define-public pict
@@ -621,7 +622,14 @@ pattern.")
(arguments
(list
#:configure-flags
- #~(list "-DCATCH_DEVELOPMENT_BUILD=ON"
+ #~(list #$@(match (%current-system)
+ ((or "x86_64-linux" "i686-linux")
+ ;; Tests fail on i686-linux without SSE2 for floats, see
+ ;; upstream report
+ ;; <https://github.com/catchorg/Catch2/issues/2796>.
+ '("-DCMAKE_CXX_FLAGS=-msse2 -mfpmath=sse"))
+ (_ '()))
+ "-DCATCH_DEVELOPMENT_BUILD=ON"
"-DCATCH_ENABLE_WERROR=OFF"
"-DBUILD_SHARED_LIBS=ON")))
(inputs (list python-wrapper))