summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:32:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:26 -0400
commite7a41b15cee67739546d743670af266035d71036 (patch)
treef515c840f6353d3568aadf9af5ebdb806b478006 /gnu/packages/check.scm
parent55fc0947d484f13dec89a4897b9313c8079b1d98 (diff)
downloadguix-patches-e7a41b15cee67739546d743670af266035d71036.tar
guix-patches-e7a41b15cee67739546d743670af266035d71036.tar.gz
gnu: Remove python2-pytest-warnings.
* gnu/packages/check.scm (python2-pytest-warnings): Delete variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 197205a47e..421b9bf202 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2598,14 +2598,7 @@ recognize TestCases.")
"Python-pytest-warnings is a pytest plugin to list Python warnings in
pytest report.")
(license license:expat)
- (properties `((python2-variant . ,(delay python2-pytest-warnings))
- ;; This package is part of pytest as of version 3.1.0.
- (superseded . ,python-pytest)))))
-
-(define-public python2-pytest-warnings
- (package (inherit (package-with-python2
- (strip-python2-variant python-pytest-warnings)))
- (properties `((superseded . ,python2-pytest)))))
+ (properties `((superseded unquote python-pytest)))))
(define-public python-pytest-capturelog
(package