summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:31:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:42:04 +0300
commit64c043e63a4be97f59fd1906c47973a74eedda67 (patch)
tree37b15dfb4830e4f874edca87b521b6e9cdc3c81b /gnu/packages/check.scm
parentb1f763de54dc2b8e240d0f01f7948ce76f67243e (diff)
parent75af73e1b7ac58770122d8831faa3a8158638bb0 (diff)
downloadguix-patches-64c043e63a4be97f59fd1906c47973a74eedda67.tar
guix-patches-64c043e63a4be97f59fd1906c47973a74eedda67.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm315
1 files changed, 9 insertions, 306 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ee9f886917..5c8b547c0d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
@@ -818,19 +818,8 @@ but it works for any C/C++ project.")
(description
"Parameterized is a Python library that aims to fix parameterized testing
for every Python test framework. It supports nose, py.test, and unittest.")
- (properties `((python2-variant . ,(delay python2-parameterized))))
(license license:bsd-2)))
-(define-public python2-parameterized
- (let ((base (package-with-python2 (strip-python2-variant
- python-parameterized))))
- (package/inherit
- base
- (source
- (origin
- (inherit (package-source base))
- (patches (search-patches "python2-parameterized-docstring-test.patch")))))))
-
(define-public python-minimock
(package
(name "python-minimock")
@@ -849,9 +838,6 @@ for every Python test framework. It supports nose, py.test, and unittest.")
doctest.")
(license license:expat)))
-(define-public python2-minimock
- (package-with-python2 python-minimock))
-
(define-public python-mock
(package
(name "python-mock")
@@ -876,18 +862,8 @@ doctest.")
of your system under test with mock objects and make assertions about how they
have been used. This library is now part of Python (since Python 3.3),
available via the @code{unittest.mock} module.")
- (properties `((python2-variant . ,(delay python2-mock))))
(license license:expat)))
-(define-public python2-mock
- (let ((base (package-with-python2
- (strip-python2-variant python-mock))))
- (package/inherit base
- (propagated-inputs
- `(("python2-functools32" ,python2-functools32)
- ("python2-funcsigs" ,python2-funcsigs)
- ,@(package-propagated-inputs base))))))
-
;;; This package is unmaintained (see the note at the top of doc/index.rst).
(define-public python-nose
(package
@@ -911,17 +887,7 @@ available via the @code{unittest.mock} module.")
(synopsis "Python testing library")
(description
"Nose extends the unittest library to make testing easier.")
- (license license:lgpl2.0+)
- (properties `((python2-variant . ,(delay python2-nose))))))
-
-(define-public python2-nose
- (let ((base (package-with-python2
- (strip-python2-variant python-nose))))
- (package/inherit base
- (arguments (substitute-keyword-arguments (package-arguments base)
- ((#:phases phases)
- `(modify-phases ,phases
- (delete 'invoke-2to3))))))))
+ (license license:lgpl2.0+)))
(define-public python-nose2
(package
@@ -947,9 +913,6 @@ better plugin api, being easier for users to configure, and simplifying internal
interfaces and processes.")
(license license:bsd-2)))
-(define-public python2-nose2
- (package-with-python2 python-nose2))
-
(define-public python-unittest2
(package
(name "python-unittest2")
@@ -980,9 +943,6 @@ interfaces and processes.")
standard library.")
(license license:psfl)))
-(define-public python2-unittest2
- (package-with-python2 python-unittest2))
-
(define-public python-pytest
(package
(name "python-pytest")
@@ -1043,77 +1003,17 @@ standard library.")
"Pytest is a testing tool that provides auto-discovery of test modules
and functions, detailed info on failing assert statements, modular fixtures,
and many external plugins.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-pytest))))))
+ (license license:expat)))
(define-public python-pytest-6 python-pytest)
-;; Pytest 4.x are the last versions that support Python 2.
-(define-public python2-pytest
- (package
- (inherit (strip-python2-variant python-pytest))
- (name "python2-pytest")
- (version "4.6.11")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "pytest" version))
- (sha256
- (base32
- "0ls3pqr86xgif6bphsb6wrww9r2vc7p7a2naq8zcq8115wwq5yjh"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- ,@(package-arguments python-pytest)))
- (propagated-inputs
- `(("python-atomicwrites" ,python2-atomicwrites)
- ("python-attrs" ,python2-attrs-bootstrap)
- ("python-funcsigs" ,python2-funcsigs)
- ("python-importlib-metadata" ,python2-importlib-metadata-bootstrap)
- ("python-more-itertools" ,python2-more-itertools)
- ("python-packaging" ,python2-packaging-bootstrap)
- ("python-pathlib2" ,python2-pathlib2)
- ("python-pluggy" ,python2-pluggy)
- ("python-py" ,python2-py)
- ("python-six" ,python2-six-bootstrap)
- ("python-wcwidth" ,python2-wcwidth)))
- (native-inputs
- `(("bash" ,bash) ;tests require 'compgen'
- ("python-hypothesis" ,python2-hypothesis)
- ("python-nose" ,python2-nose)
- ("python-mock" ,python2-mock)
- ("python-pytest" ,python2-pytest-bootstrap)
- ("python-setuptools-scm" ,python2-setuptools-scm)))))
-
(define-public python-pytest-bootstrap
(package
- (inherit (strip-python2-variant python-pytest))
+ (inherit python-pytest)
(name "python-pytest-bootstrap")
(native-inputs (list python-iniconfig python-setuptools-scm
python-toml))
- (arguments `(#:tests? #f))
- (properties `((python2-variant . ,(delay python2-pytest-bootstrap))))))
-
-(define-public python2-pytest-bootstrap
- (hidden-package
- (package/inherit
- python2-pytest
- (name "python2-pytest-bootstrap")
- (arguments
- (substitute-keyword-arguments (package-arguments python2-pytest)
- ((#:tests? _ #f) #f)))
- (native-inputs
- `(("python-setuptools-scm" ,python2-setuptools-scm)))
- (propagated-inputs
- `(("python-atomicwrites" ,python2-atomicwrites)
- ("python-attrs" ,python2-attrs-bootstrap)
- ("python-funcsigs" ,python2-funcsigs-bootstrap)
- ("python-importlib-metadata" ,python2-importlib-metadata-bootstrap)
- ("python-more-itertools" ,python2-more-itertools)
- ("python-packaging" ,python2-packaging-bootstrap)
- ("python-pathlib2" ,python2-pathlib2-bootstrap)
- ("python-pluggy" ,python2-pluggy-bootstrap)
- ("python-py" ,python2-py)
- ("python-wcwidth" ,python2-wcwidth))))))
+ (arguments `(#:tests? #f))))
(define-public python-pytest-assume
(package
@@ -1178,38 +1078,6 @@ distributed testing in both @code{load} and @code{each} modes. It also
supports coverage of subprocesses.")
(license license:expat)))
-(define-public python2-pytest-cov
- (package
- (name "python2-pytest-cov")
- (version "2.8.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-cov" version))
- (sha256
- (base32 "0avzlk9p4nc44k7lpx9109dybq71xqnggxb9f4hp0l64pbc44ryc"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- ;; Options taken from tox.ini.
- ;; TODO: make "--restructuredtext" tests pass. They currently fail
- ;; with "Duplicate implicit target name".
- (invoke "python" "./setup.py" "check"
- "--strict" "--metadata"))))))
- (propagated-inputs
- (list python2-coverage python2-pytest))
- (home-page "https://github.com/pytest-dev/pytest-cov")
- (synopsis "Pytest plugin for measuring coverage")
- (description
- "Pytest-cov produces coverage reports. It supports centralised testing and
-distributed testing in both @code{load} and @code{each} modes. It also
-supports coverage of subprocesses.")
- (license license:expat)))
-
(define-public python-pytest-httpserver
(package
(name "python-pytest-httpserver")
@@ -1344,25 +1212,6 @@ Python's @code{random.seed}.")
@file{setup.py} files can use to run tests.")
(license license:expat)))
-(define-public python2-pytest-runner
- (package-with-python2 python-pytest-runner))
-
-;; python-bleach 3.1.0 requires this ancient version of pytest-runner.
-;; Remove once no longer needed.
-(define-public python-pytest-runner-2
- (package
- (inherit python-pytest-runner)
- (version "2.12.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-runner" version))
- (sha256
- (base32
- "11ivjj9hfphkv4yfb2g74av4yy86y8gcbf7gbif0p1hcdfnxg3w6"))))))
-
-(define-public python2-pytest-runner-2
- (package-with-python2 python-pytest-runner-2))
-
(define-public python-pytest-lazy-fixture
(package
(name "python-pytest-lazy-fixture")
@@ -1434,29 +1283,8 @@ around the patching API provided by the @code{mock} package, but with the
benefit of not having to worry about undoing patches at the end of a test.
The mocker fixture has the same API as @code{mock.patch}, supporting the
same arguments.")
- (properties `((python2-variant . ,(delay python2-pytest-mock))))
(license license:expat)))
-(define-public python2-pytest-mock
- (let ((base (package-with-python2
- (strip-python2-variant python-pytest-mock))))
- (package/inherit base
- (version "1.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-mock" version))
- (sha256
- (base32
- "1i5mg3ff1qk0wqfcxfz60hwy3q5dskdp36i10ckigkzffg8hc3ad"))))
- (arguments
- `(#:python ,python-2))
- (native-inputs
- `(("python2-setuptools-scm" ,python2-setuptools-scm)))
- (propagated-inputs
- `(("python2-mock" ,python2-mock)
- ("python2-pytest" ,python2-pytest))))))
-
(define-public python-pytest-xdist
(package
(name "python-pytest-xdist")
@@ -1509,9 +1337,6 @@ program code to a remote location, executes there, and then syncs the
result back.")
(license license:expat)))
-(define-public python2-pytest-xdist
- (package-with-python2 python-pytest-xdist))
-
(define-public python-pytest-xdist-next
(package/inherit python-pytest-xdist
(name "python-pytest-xdist")
@@ -1910,9 +1735,6 @@ library to determine which lines are executable, and which have been
executed.")
(license license:bsd-3)))
-(define-public python2-coverage
- (package-with-python2 python-coverage))
-
(define-public python-pytest-asyncio
(package
(name "python-pytest-asyncio")
@@ -1973,9 +1795,6 @@ and @code{nose2-cov}. It is useful for developing coverage plugins for these
testing frameworks.")
(license license:expat)))
-(define-public python2-cov-core
- (package-with-python2 python-cov-core))
-
(define-public python-codecov
(package
(name "python-codecov")
@@ -2064,9 +1883,6 @@ tools for mocking system commands and recording calls to those.")
(home-page "https://github.com/trentm/testlib")
(license license:expat)))
-(define-public python2-testlib
- (package-with-python2 python-testlib))
-
;;; The software provided by this package was integrated into pytest 2.8.
(define-public python-pytest-cache
(package
@@ -2087,9 +1903,6 @@ the last py.test invocation.")
(home-page "https://bitbucket.org/hpk42/pytest-cache/")
(license license:expat)))
-(define-public python2-pytest-cache
- (package-with-python2 python-pytest-cache))
-
(define-public python-pytest-localserver
(package
(name "python-pytest-localserver")
@@ -2160,9 +1973,6 @@ normally the case.")
(home-page "https://github.com/untitaker/pytest-subtesthack/")
(license license:unlicense)))
-(define-public python2-pytest-subtesthack
- (package-with-python2 python-pytest-subtesthack))
-
(define-public python-pytest-sugar
(package
(name "python-pytest-sugar")
@@ -2207,8 +2017,7 @@ much larger range of examples than you would ever want to write by hand. It’s
based on the Haskell library, Quickcheck, and is designed to integrate
seamlessly into your existing Python unit testing work flow.")
(home-page "https://github.com/HypothesisWorks/hypothesis")
- (license license:mpl2.0)
- (properties `((python2-variant . ,(delay python2-hypothesis))))))
+ (license license:mpl2.0)))
;;; TODO: Make the default python-hypothesis in the next rebuild cycle.
(define-public python-hypothesis-next
@@ -2225,22 +2034,6 @@ seamlessly into your existing Python unit testing work flow.")
(modify-inputs (package-propagated-inputs python-hypothesis)
(append python-pytest))))) ;to satisfy the sanity-check phase
-;; This is the last version of Hypothesis that supports Python 2.
-(define-public python2-hypothesis
- (let ((hypothesis (package-with-python2
- (strip-python2-variant python-hypothesis))))
- (package (inherit hypothesis)
- (version "4.57.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "hypothesis" version))
- (sha256
- (base32
- "183gpxbfcdhdqzlahkji5a71n6lmvgqsbkcb0ihqad51n2j6jhrw"))))
- (propagated-inputs
- (modify-inputs (package-propagated-inputs hypothesis)
- (prepend python2-enum34))))))
-
(define-public python-hypothesmith
(package
(name "python-hypothesmith")
@@ -2430,9 +2223,6 @@ a Pytest test execution.")
(description "Pytest plugin for checking PEP8 compliance.")
(license license:expat)))
-(define-public python2-pytest-pep8
- (package-with-python2 python-pytest-pep8))
-
(define-public python-pytest-perf
(package
(name "python-pytest-perf")
@@ -2522,9 +2312,6 @@ each of the environments.")
(description "Pytest plugin for checking Python source code with pyflakes.")
(license license:expat)))
-(define-public python2-pytest-flakes
- (package-with-python2 python-pytest-flakes))
-
(define-public python-coverage-test-runner
(package
(name "python-coverage-test-runner")
@@ -2555,9 +2342,6 @@ unit tests and failing them if the unit test module does not exercise all
statements in the module it tests.")
(license license:gpl3+)))
-(define-public python2-coverage-test-runner
- (package-with-python2 python-coverage-test-runner))
-
(define-public python-pylint
(package
(name "python-pylint")
@@ -2629,9 +2413,6 @@ cases. Since they are TestCase subclasses, they work with other test suites tha
recognize TestCases.")
(license license:bsd-2)))
-(define-public python2-python-paramunittest
- (package-with-python2 python-paramunittest))
-
(define-public python-pytest-warnings
(package
(name "python-pytest-warnings")
@@ -2652,14 +2433,7 @@ recognize TestCases.")
"Python-pytest-warnings is a pytest plugin to list Python warnings in
pytest report.")
(license license:expat)
- (properties `((python2-variant . ,(delay python2-pytest-warnings))
- ;; This package is part of pytest as of version 3.1.0.
- (superseded . ,python-pytest)))))
-
-(define-public python2-pytest-warnings
- (package (inherit (package-with-python2
- (strip-python2-variant python-pytest-warnings)))
- (properties `((superseded . ,python2-pytest)))))
+ (properties `((superseded unquote python-pytest)))))
(define-public python-pytest-capturelog
(package
@@ -2681,9 +2455,6 @@ pytest report.")
"Python-pytest-catchlog is a pytest plugin to catch log messages.")
(license license:expat)))
-(define-public python2-pytest-capturelog
- (package-with-python2 python-pytest-capturelog))
-
(define-public python-pytest-catchlog
(package
(name "python-pytest-catchlog")
@@ -2707,9 +2478,6 @@ pytest report.")
a fork of pytest-capturelog.")
(license license:expat)))
-(define-public python2-pytest-catchlog
- (package-with-python2 python-pytest-catchlog))
-
(define-public python-nosexcover
(package
(name "python-nosexcover")
@@ -2733,9 +2501,6 @@ It will honor all the options you pass to the Nose coverage plugin,
especially -cover-package.")
(license license:expat)))
-(define-public python2-nosexcover
- (package-with-python2 python-nosexcover))
-
(define-public python-discover
(package
(name "python-discover")
@@ -2756,9 +2521,6 @@ especially -cover-package.")
backported from Python 2.7 for Python 2.4+.")
(license license:bsd-3)))
-(define-public python2-discover
- (package-with-python2 python-discover))
-
(define-public behave
(package
(name "behave")
@@ -2859,9 +2621,6 @@ JSON APIs with Behave.")
@command{nosetests} command of the Python Nose unit test framework.")
(license license:bsd-3)))
-(define-public python2-rednose
- (package-with-python2 python-rednose))
-
(define-public python-nose-random
(package
(name "python-nose-random")
@@ -2912,9 +2671,6 @@ by resetting it to a repeatable number for each test, enabling the tests to
create data based on random numbers and yet remain repeatable.")
(license license:bsd-3)))
-(define-public python2-nose-randomly
- (package-with-python2 python-nose-randomly))
-
(define-public python-nose-timer
(package
(name "python-nose-timer")
@@ -2933,9 +2689,6 @@ create data based on random numbers and yet remain repeatable.")
(description "Shows how much time was needed to run individual tests.")
(license license:expat)))
-(define-public python2-nose-timer
- (package-with-python2 python-nose-timer))
-
(define-public python-freezegun
(package
(name "python-freezegun")
@@ -2966,37 +2719,6 @@ create data based on random numbers and yet remain repeatable.")
time by mocking the datetime module.")
(license license:asl2.0)))
-(define-public python2-freezegun
- (package
- (name "python2-freezegun")
- (version "0.3.14")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "freezegun" version))
- (sha256
- (base32 "0al75mk829j1izxi760b7yjnknjihyfhp2mvi5qiyrxb9cpxwqk2"))))
- (build-system python-build-system)
- (native-inputs
- (list python2-mock python2-pytest))
- (propagated-inputs
- (list python2-six python2-dateutil))
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- ;; The tests are normally executed via `make test`, but the PyPi
- ;; package does not include the Makefile.
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
- (home-page "https://github.com/spulec/freezegun")
- (synopsis "Test utility for mocking the datetime module")
- (description
- "FreezeGun is a library that allows your python tests to travel through
-time by mocking the datetime module.")
- (license license:asl2.0)))
-
(define-public python-flexmock
(package
(name "python-flexmock")
@@ -3015,9 +2737,6 @@ time by mocking the datetime module.")
mocks, stubs and fakes.")
(license license:bsd-3)))
-(define-public python2-flexmock
- (package-with-python2 python-flexmock))
-
(define-public python-flaky
(package
(name "python-flaky")
@@ -3044,9 +2763,6 @@ those tests or marking them to @code{@@skip}, they can be automatically
retried.")
(license license:asl2.0)))
-(define-public python2-flaky
- (package-with-python2 python-flaky))
-
(define-public python-pyhamcrest
(package
(name "python-pyhamcrest")
@@ -3298,23 +3014,10 @@ under test to interact with a fake file system instead of the real file
system. The code under test requires no modification to work with pyfakefs.")
(license license:asl2.0)))
-;; This minimal variant is used to avoid a circular dependency between
-;; python2-importlib-metadata, which requires pyfakefs for its tests, and
-;; python2-pytest, which requires python2-importlib-metadata.
-(define-public python2-pyfakefs-bootstrap
- (hidden-package
- (package
- (inherit (package-with-python2 python-pyfakefs))
- (name "python2-pyfakefs-bootstrap")
- (native-inputs '())
- (arguments
- `(#:python ,python-2
- #:tests? #f)))))
-
(define-public python-aiounittest
(package
(name "python-aiounittest")
- (version "1.4.0")
+ (version "1.4.1")
;; Pypi package lacks tests.
(source
(origin (method git-fetch)
@@ -3324,7 +3027,7 @@ system. The code under test requires no modification to work with pyfakefs.")
(file-name (git-file-name name version))
(sha256
(base32
- "0hql5mw62lclrpblbh7xvinwjfcdcfvhhlvl7xlq2hi9isjq1c8r"))))
+ "10x7ds09b9415r92f7g9714gxixvvq3bm5mnh29ml9aba8blcb0n"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases