summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorHugo Lecomte <hugo.lecomte@inria.fr>2021-07-05 09:29:27 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-09 11:58:51 +0200
commite31979c3a50a781d8d0341659666e865dd1d1403 (patch)
tree63b97c40a1b306b48740e846a3d60d32774d0ca0 /gnu/packages/check.scm
parent778ae273e91f67022640dfa3aa951467558e814b (diff)
downloadguix-patches-e31979c3a50a781d8d0341659666e865dd1d1403.tar
guix-patches-e31979c3a50a781d8d0341659666e865dd1d1403.tar.gz
gnu: Add python-pytest-regressions.
* gnu/packages/check.scm (python-pytest-regressions): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 14ffee25a0..637449351a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -71,6 +71,7 @@
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages python-science)
#:use-module (gnu packages time)
#:use-module (gnu packages xml)
#:use-module (guix utils)
@@ -2942,3 +2943,37 @@ skipped if any of the dependencies did fail or has been skipped.")
"This package provides a Pytest plugin for manipulating test data
directories and files.")
(license license:expat)))
+
+(define-public python-pytest-regressions
+ (package
+ (name "python-pytest-regressions")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-regressions" version))
+ (sha256
+ (base32
+ "05jpsvv8rj8i4x24fphpnar5dl4s6d6bw6ikjk5d8v96rdviz9qm"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pytest-datadir" ,python-pytest-datadir)
+ ("python-pyyaml" ,python-pyyaml)))
+ (native-inputs
+ `(("python-matplotlib" ,python-matplotlib)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-pillow" ,python-pillow)
+ ("python-pre-commit" ,python-pre-commit)
+ ("python-restructuredtext-lint"
+ ,python-restructuredtext-lint)
+ ("python-tox" ,python-tox)
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/ESSS/pytest-regressions")
+ (synopsis "Easy to use fixtures to write regression tests")
+ (description
+ "This plugin makes it simple to test general data, images, files, and numeric
+tables by saving expected data in a data directory (courtesy of pytest-datadir)
+that can be used to verify that future runs produce the same data.")
+ (license license:expat)))