summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-11 16:19:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-11 16:21:15 +0300
commit43bc7dd39c3d7891c9f35a8372a520f4afdc7875 (patch)
treed73df4ba5a54ff28b71e97fa07be0ecc596c2c19 /gnu/packages/check.scm
parentdb8e8eb17129d811818babd31c04b26d89df987a (diff)
downloadguix-patches-43bc7dd39c3d7891c9f35a8372a520f4afdc7875.tar
guix-patches-43bc7dd39c3d7891c9f35a8372a520f4afdc7875.tar.gz
gnu: python-testtools: Honor #:tests? in check phase.
* gnu/packages/check.scm (python-testtools)[arguments]: Adjust custom 'check phase to honor #:tests.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e5bd7da5b5..ff3eb8b891 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1430,11 +1430,13 @@ subprocess and see the output as well as any file modifications.")
(inherit python-testtools-bootstrap)
(name "python-testtools")
(arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "python" "-m" "testtools.run"
- "testtools.tests.test_suite"))))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "testtools.run"
+ "testtools.tests.test_suite")))))))
(propagated-inputs
`(("python-extras" ,python-extras)
("python-fixtures" ,python-fixtures)