summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-25 13:12:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-29 01:05:27 -0400
commit66071cd85ea323292eb60258d3cef9ffaf8306d4 (patch)
tree0ffad210217ec92b61d5c2ea0a34467f2a1a6d25 /gnu/packages/check.scm
parent97a675df1b6e8b2c83c6e8137123433f981609e8 (diff)
downloadguix-patches-66071cd85ea323292eb60258d3cef9ffaf8306d4.tar
guix-patches-66071cd85ea323292eb60258d3cef9ffaf8306d4.tar.gz
gnu: python-pytest-6: Update to 6.2.4 and propagate iniconfig.
* gnu/packages/check.scm (python-pytest-6): Update to 6.2.4. Fix typo. Removing trailing #t. [native-inputs]: Delete the extraneous python-mock input. Move python-iniconfig to... [propagated-inputs]: ... here.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 0ced2a4562..0480fae290 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1002,14 +1002,14 @@ and many external plugins.")
(define-public python-pytest-6
(package
(inherit (strip-python2-variant python-pytest))
- (version "6.1.2")
+ (version "6.2.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest" version))
(sha256
(base32
- "0gl2sdm322vzmsh5k4f8kj9raiq2y7kdinnca4m45ifvii5fk9y0"))))
+ "0jy5f83la1864ss42dhsi1mcm5nl79d8bjg7wk474nlw1c5avg2h"))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1019,24 +1019,24 @@ and many external plugins.")
(if tests?
(invoke "pytest" "-vv" "-k"
(string-append
- ;; This test involve the /usr directory, and fails.
+ ;; This test involves the /usr directory, and fails.
" not test_argcomplete"
;; These test do not honor the isatty detection and
;; fail.
" and not test_code_highlight"
" and not test_color_yes"))
- (format #t "test suite not run~%"))
- #t)))))
+ (format #t "test suite not run~%")))))))
(propagated-inputs
(append (alist-delete "python-py"
(package-propagated-inputs python-pytest))
- `(("python-py" ,python-py-next))))
+ `(("python-iniconfig" ,python-iniconfig)
+ ("python-py" ,python-py-next))))
(native-inputs
- (append (alist-delete "python-pytest"
- (package-native-inputs python-pytest))
- `(("python-pytest" ,python-pytest-6-bootstrap)
- ("python-toml" ,python-toml)
- ("python-iniconfig" ,python-iniconfig))))))
+ (append (fold alist-delete (package-native-inputs python-pytest)
+ '("python-mock"
+ "python-pytest"))
+ `(("python-pytest" ,python-pytest-6-bootstrap)
+ ("python-toml" ,python-toml))))))
;; Pytest 4.x are the last versions that support Python 2.
(define-public python2-pytest