summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-08-26 11:15:38 -0400
committerEfraim Flashner <efraim@flashner.co.il>2021-08-26 23:58:24 +0300
commit0e02ce8d49cf3af0de9a976acc3529136a741d4b (patch)
tree20340530a857589fd96a90a13aa88976a287e182 /gnu/packages/check.scm
parentdb600ee2c1b690293c2c94a72beec7e76165f5f1 (diff)
downloadguix-patches-0e02ce8d49cf3af0de9a976acc3529136a741d4b.tar
guix-patches-0e02ce8d49cf3af0de9a976acc3529136a741d4b.tar.gz
gnu: python-pytest-xprocess: Update to 0.18.1.
* gnu/packages/check.scm (python-pytest-xprocess): Update to 0.18.1. [native-inputs]: Add python-setuptools-scm. [home-page]: Fix linter warning to follow permanent redirect. Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name> Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index fd4bb4cfda..0ced2a4562 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1908,14 +1908,16 @@ framework which enables you to test server connections locally.")
(define-public python-pytest-xprocess
(package
(name "python-pytest-xprocess")
- (version "0.9.1")
+ (version "0.18.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "pytest-xprocess" version))
(sha256
(base32
- "17zlql1xqw3ywcgwwbqmw633aly99lab12hm02asr8awvg5603pp"))))
+ "0rm2rchrr63imn44xk5slwydxf8gvy579524qcxq7dc42pnk17zx"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
(propagated-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-cache" ,python-pytest-cache)
@@ -1923,7 +1925,7 @@ framework which enables you to test server connections locally.")
(synopsis "Pytest plugin to manage external processes across test runs")
(description "Pytest-xprocess is an experimental py.test plugin for managing
processes across test runs.")
- (home-page "https://bitbucket.org/pytest-dev/pytest-xprocess")
+ (home-page "https://github.com/pytest-dev/pytest-xprocess")
(license license:expat)))
(define-public python-pytest-subtesthack