summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 15:08:28 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 16:33:09 -0500
commitc65adccb547fe9d459bbb877b0b9e61ff8d187da (patch)
tree56fbffc92ddceaa978336a25343584192a9da7ef /gnu/packages/check.scm
parent274deb0fa187b5cf0b9d252d7b857bb2797f733d (diff)
downloadguix-patches-c65adccb547fe9d459bbb877b0b9e61ff8d187da.tar
guix-patches-c65adccb547fe9d459bbb877b0b9e61ff8d187da.tar.gz
gnu: python-hypothesis: Update to 6.0.2
* gnu/packages/check.scm (python-hypothesis): Update to 6.0.2. (python-hypothesis-5.23): Delete variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c7a538ba48..4f8d2f3d3e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1871,13 +1871,13 @@ instantly.")
(define-public python-hypothesis
(package
(name "python-hypothesis")
- (version "5.4.1")
+ (version "6.0.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "hypothesis" version))
(sha256
(base32
- "0zn09bn6hadk4vxl6jy8bkjr5fz8mrhin3z46w7pq5qgbaycr89p"))))
+ "0wj7ip779naf2n076nylf2gi0sjz68z1ir9d9r2rgs7br18naqdf"))))
(build-system python-build-system)
(arguments
;; XXX: Tests are not distributed with the PyPI archive.
@@ -1894,18 +1894,6 @@ seamlessly into your existing Python unit testing work flow.")
(license license:mpl2.0)
(properties `((python2-variant . ,(delay python2-hypothesis))))))
-(define-public python-hypothesis-5.23
- (package
- (inherit python-hypothesis)
- (version "5.23.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "hypothesis" version))
- (sha256
- (base32
- "0sy1v6nyxg4rjcf3rlr8nalb7wqd9nccpb2lzkchbj5an13ysf1h"))))
- (home-page "https://github.com/HypothesisWorks/hypothesis")))
-
;; This is the last version of Hypothesis that supports Python 2.
(define-public python2-hypothesis
(let ((hypothesis (package-with-python2