summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-20 11:00:15 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:42 -0500
commit2fa2b91d59f0c2eb0b1996d49b50750a0f5e5685 (patch)
treece1dc7a98f756821c64c8bca17e404161e583a07 /gnu/packages/check.scm
parentb9839ee1c57455c199964bfbb212659080982c66 (diff)
downloadguix-patches-2fa2b91d59f0c2eb0b1996d49b50750a0f5e5685.tar
guix-patches-2fa2b91d59f0c2eb0b1996d49b50750a0f5e5685.tar.gz
gnu: python-pylint: Update to 2.12.2.
* gnu/packages/check.scm (python-pylint): Update to 2.12.2. [phases]{check}: Override phase. [native-inputs]: Remove python-pytest-benchmark, python-pytest-runner. [propagated-inputs]: Add python-platformdirs, python-typing-extensions. [synopsis]: Streamline.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm28
1 files changed, 22 insertions, 6 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5dcf8958f1..f6f22d3396 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2255,7 +2255,7 @@ statements in the module it tests.")
(define-public python-pylint
(package
(name "python-pylint")
- (version "2.9.6")
+ (version "2.12.2")
(source
(origin
(method git-fetch)
@@ -2264,15 +2264,31 @@ statements in the module it tests.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "15yw69v1cj6zkndk60c2g0dgl0khh8bfm1lrwhjffpdjfc7nkc9a"))))
+ (base32 "0spmy7j1vvh55shzgma80q61y0d1cj45dcgslb4g5w3y602miq5i"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The unused but collected 'primer'-related test files require
+ ;; the extraneous 'git' Python module; remove them.
+ (delete-file "tests/primer/test_primer_external.py")
+ (delete-file "tests/testutils/test_package_to_lint.py")
+ (setenv "HOME" "/tmp")
+ (invoke "pytest" "-k" "test_functional")))))))
(native-inputs
- (list python-pytest python-pytest-benchmark python-pytest-runner))
+ (list python-pytest))
(propagated-inputs
- (list python-astroid python-isort python-mccabe python-toml))
+ (list python-astroid
+ python-isort
+ python-mccabe
+ python-platformdirs
+ python-toml
+ python-typing-extensions))
(home-page "https://github.com/PyCQA/pylint")
- (synopsis "Python source code analyzer which looks for coding standard
-errors")
+ (synopsis "Advanced Python code static checker")
(description "Pylint is a Python source code analyzer which looks
for programming errors, helps enforcing a coding standard and sniffs
for some code smells (as defined in Martin Fowler's Refactoring book).