summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-01-07 13:35:11 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:44 -0500
commit355d87a0a562bb84b416163d4804919c497732b5 (patch)
tree58123e169508c7d862e4d8e9f028ad4a87315b30 /gnu/packages/check.scm
parentda3c8e53c4ab18ddf1a2d44c5cdb2d44fc47a44f (diff)
downloadguix-patches-355d87a0a562bb84b416163d4804919c497732b5.tar
guix-patches-355d87a0a562bb84b416163d4804919c497732b5.tar.gz
gnu: python-pytest-pep8: Fix package.
* gnu/packages/check.scm (python-pytest-pep8)[arguments]: Remove dependency on pytest-cache and add proper 'check phase.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index defa59415c..ce00927c53 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1985,7 +1985,18 @@ failures.")
"06032agzhw1i9d9qlhfblnl3dw5hcyxhagn7b120zhrszbjzfbh3"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f)) ; Fails with recent pytest and pep8. See upstream issues #8 and #12.
+ `(#:tests? #f ; Fails with recent pytest and pep8. See upstream issues #8 and #12.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dependencies
+ (lambda _
+ (substitute* "setup.py"
+ (("'pytest-cache', ") "")))) ; Included in recent pytest
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v")))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(propagated-inputs