summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-06-11 23:52:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-06-11 23:52:15 +0200
commita032b4454b3fc67e11e9fc2d8c2345288065fa29 (patch)
treec208124b79dbd2224b68c52106aa72ff2ebfa7ab /gnu/packages/cdrom.scm
parentb5724230fed2d043206df20d12a45bb962b7ee77 (diff)
parent6321ce42ab4d9ab788d858cb19bde4aa7a0e3ecc (diff)
downloadguix-patches-a032b4454b3fc67e11e9fc2d8c2345288065fa29.tar
guix-patches-a032b4454b3fc67e11e9fc2d8c2345288065fa29.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm28
1 files changed, 17 insertions, 11 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 5f9117c637..5d45d07288 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -188,9 +188,11 @@ files.")
(patches (search-patches "cdparanoia-fpic.patch"))
(modules '((guix build utils)))
(snippet
- ;; Make libraries respect LDFLAGS.
- '(substitute* '("paranoia/Makefile.in" "interface/Makefile.in")
- (("-Wl,-soname") "$(LDFLAGS) -Wl,-soname")))))
+ '(begin
+ ;; Make libraries respect LDFLAGS.
+ (substitute* '("paranoia/Makefile.in" "interface/Makefile.in")
+ (("-Wl,-soname") "$(LDFLAGS) -Wl,-soname"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there is no check target
@@ -449,9 +451,11 @@ the data.")
"0qrcvn7227qaayjcd5rm7z0k5q89qfy5qkdgwr5pd7ih0va8rmpz"))
(modules '((guix build utils)))
(snippet
- '(substitute* "Makefile"
- (("/usr/bin/install")
- "install")))))
+ '(begin
+ (substitute* "Makefile"
+ (("/usr/bin/install")
+ "install"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f
@@ -479,11 +483,13 @@ from an audio CD.")
"1msm5snyckynbspz54p9krarn7v9izsi7qyyi2z5y4cinw36xv3h"))
(modules '((guix build utils)))
(snippet
- '(substitute* "Makefile"
- (("/usr/bin/install")
- "install")
- (("^etcdir = .*$")
- (string-append "etcdir = $(prefix)/etc\n"))))))
+ '(begin
+ (substitute* "Makefile"
+ (("/usr/bin/install")
+ "install")
+ (("^etcdir = .*$")
+ (string-append "etcdir = $(prefix)/etc\n")))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:phases