summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-29 20:03:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-01-30 09:25:32 +0200
commit7bf98da98bd07923956e99e753ac7544333fd202 (patch)
treedf1953426407627ae2ce1dbeef6e08f6eb51c8b7 /gnu/packages/calendar.scm
parent144c95032e517bb8ce466b930fe91506bcc92b2b (diff)
downloadguix-patches-7bf98da98bd07923956e99e753ac7544333fd202.tar
guix-patches-7bf98da98bd07923956e99e753ac7544333fd202.tar.gz
gnu: libhdate: Fix pkg-config file.
* gnu/packages/calendar.scm (libhdate)[source]: Add snippet to adjust the pkg-config file to have the correct prefix. Change-Id: I5273f732a4e4e512057aa8bc1ecd40a81ec7828e
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 991995daf7..042daa53f5 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2016, 2017, 2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020, 2022-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016, 2021 Stefan Reichoer <stefan@xsteve.at>
;;; Copyright © 2018, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -292,7 +292,11 @@ proper handling of holidays.")
version "/" name "-" version ".tar.bz2"))
(sha256
(base32
- "0qkpq412p78znw8gckwcx3l0wcss9s0dgw1pvjb1ih2pxf6hm4rw"))))
+ "0qkpq412p78znw8gckwcx3l0wcss9s0dgw1pvjb1ih2pxf6hm4rw"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (substitute* "libhdate.pc.in"
+ (("prefix=/usr") "prefix=@prefix@"))))))
(build-system gnu-build-system)
(home-page "http://libhdate.sourceforge.net/")
(synopsis "Library to use Hebrew dates")