summaryrefslogtreecommitdiff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/busybox.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index f3652813ed..17b91da59f 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -106,11 +106,11 @@
(apply invoke "make"
(string-append "CONFIG_PREFIX=" out)
"install" make-flags)))))))
- (native-inputs `(("perl" ,perl) ; needed to generate the man pages (pod2man)
- ;; The following are needed by the tests.
- ("inetutils" ,inetutils)
- ("which" ,(@ (gnu packages base) which))
- ("zip" ,zip)))
+ (native-inputs (list perl ; needed to generate the man pages (pod2man)
+ ;; The following are needed by the tests.
+ inetutils
+ (@ (gnu packages base) which)
+ zip))
(synopsis "Many common UNIX utilities in a single executable")
(description "BusyBox combines tiny versions of many common UNIX utilities
into a single small executable. It provides a fairly complete environment for
@@ -162,7 +162,7 @@ any small or embedded system.")
(let ((out (assoc-ref outputs "out")))
(delete-file-recursively (string-append out "/usr"))))))
#:test-target "tests"))
- (native-inputs `(("bc" ,bc)))
+ (native-inputs (list bc))
(synopsis "Many common UNIX utilities in a single executable")
(description "ToyBox combines tiny versions of many common UNIX utilities
into a single small executable. It provides a fairly complete environment for