summaryrefslogtreecommitdiff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
commit6dffced09ecda024e0884e352778c221ad066fd6 (patch)
tree1707e8d8df4d9c47317a39ab6abbfc2ca66a6c29 /gnu/packages/busybox.scm
parentb603554ed044638dd40b6863d5dada59eefe03b8 (diff)
parente3196755e60ba7f1ed9d432e73f26a85e0c8893c (diff)
downloadguix-patches-6dffced09ecda024e0884e352778c221ad066fd6.tar
guix-patches-6dffced09ecda024e0884e352778c221ad066fd6.tar.gz
Merge branch 'core-updates-frozen' into 'master'.
At last!
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index f3652813ed..17b91da59f 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -106,11 +106,11 @@
(apply invoke "make"
(string-append "CONFIG_PREFIX=" out)
"install" make-flags)))))))
- (native-inputs `(("perl" ,perl) ; needed to generate the man pages (pod2man)
- ;; The following are needed by the tests.
- ("inetutils" ,inetutils)
- ("which" ,(@ (gnu packages base) which))
- ("zip" ,zip)))
+ (native-inputs (list perl ; needed to generate the man pages (pod2man)
+ ;; The following are needed by the tests.
+ inetutils
+ (@ (gnu packages base) which)
+ zip))
(synopsis "Many common UNIX utilities in a single executable")
(description "BusyBox combines tiny versions of many common UNIX utilities
into a single small executable. It provides a fairly complete environment for
@@ -162,7 +162,7 @@ any small or embedded system.")
(let ((out (assoc-ref outputs "out")))
(delete-file-recursively (string-append out "/usr"))))))
#:test-target "tests"))
- (native-inputs `(("bc" ,bc)))
+ (native-inputs (list bc))
(synopsis "Many common UNIX utilities in a single executable")
(description "ToyBox combines tiny versions of many common UNIX utilities
into a single small executable. It provides a fairly complete environment for