summaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-10-09 20:12:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-10-09 20:40:15 +0200
commit137adfa3f87b91a8e3030fbbc05455b1d716db42 (patch)
treea39db6c2b9e17059fd8007d8f421d28e2f28637d /gnu/packages/build-tools.scm
parent51b6a1dd13d15218610ea82e9f8452010fae96d6 (diff)
downloadguix-patches-137adfa3f87b91a8e3030fbbc05455b1d716db42.tar
guix-patches-137adfa3f87b91a8e3030fbbc05455b1d716db42.tar.gz
gnu: meson: Update to 0.42.1.
* gnu/packages/build-tools.scm (meson, meson-for-build): Update to 0.42.1.
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index c535f52400..a35ce3b067 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -70,7 +70,7 @@ makes a few sacrifices to acquire fast full and incremental build times.")
(define-public meson
(package
(name "meson")
- (version "0.42.0")
+ (version "0.42.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@@ -78,7 +78,7 @@ makes a few sacrifices to acquire fast full and incremental build times.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0vyp9rkymzzzilhnf04ryszslyp9a0y0wf4agyijd4w5lcnqlcbc"))))
+ "1494hdnd40g2v6pky34j0f2iwc6kwn51vck37qwz7nl2xr17b18q"))))
(build-system python-build-system)
(inputs `(("ninja", ninja)))
(propagated-inputs `(("python" ,python)))
@@ -97,7 +97,7 @@ Python.")
(package
(inherit meson)
(name "meson-for-build")
- (version "0.42.0")
+ (version "0.42.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@@ -105,7 +105,7 @@ Python.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0vyp9rkymzzzilhnf04ryszslyp9a0y0wf4agyijd4w5lcnqlcbc"))
+ "1494hdnd40g2v6pky34j0f2iwc6kwn51vck37qwz7nl2xr17b18q"))
(patches (search-patches "meson-for-build-rpath.patch"))))
;; People should probably install "meson", not "meson-for-build".