summaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-19 00:22:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-19 00:36:29 +0100
commitde01d08bdfca8533285da16941bfcade49a7070d (patch)
tree32f13e73dad834e054b1cf8ab44c4a0a6374bb18 /gnu/packages/build-tools.scm
parenta035acc652ab14467dd8e683e888b0e13fedd326 (diff)
downloadguix-patches-de01d08bdfca8533285da16941bfcade49a7070d.tar
guix-patches-de01d08bdfca8533285da16941bfcade49a7070d.tar.gz
gnu: bear: Update to 3.0.17.
* gnu/packages/build-tools.scm (bear): Update to 3.0.17. [source]: Remove patch, and… [arguments]: …replace it with a new 'disable-TEST_BEFORE_INSTALL phase. Don't explicitly return #t from other phases. * gnu/packages/patches/bear-disable-preinstall-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm32
1 files changed, 17 insertions, 15 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index d36f7d6bb5..eb6c32d849 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Corentin Bocquillon <corentin@nybble.fr>
-;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
@@ -102,25 +102,27 @@ makes a few sacrifices to acquire fast full and incremental build times.")
(define-public bear
(package
(name "bear")
- (version "3.0.16")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rizsotto/Bear")
- (commit version)))
- (file-name (git-file-name name version))
- (patches (search-patches
- "bear-disable-preinstall-tests.patch"))
- (sha256
- (base32
- "01giv11nhjp4pvw8ssf8bxf503pabwnwnvfzmrxyxixnairwmykg"))))
+ (version "3.0.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rizsotto/Bear")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0klbk99qphibrp2944w8gn6x1dwwgrbm7f2bh530wjp5h3bpkr45"))))
(build-system cmake-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-TEST_BEFORE_INSTALL
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ ;; Delete the matching line—and comment out the next.
+ ((".*TEST_(BEFORE_INSTALL|COMMAND).*") "#"))))
(add-before 'check 'set-build-environment
(lambda _
- (setenv "CC" "gcc")
- #t))
+ (setenv "CC" "gcc")))
;; TODO: Test Configuration is Incomplete
(replace 'check
(lambda _