summaryrefslogtreecommitdiff
path: root/gnu/packages/browser-extensions.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/browser-extensions.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/browser-extensions.scm')
-rw-r--r--gnu/packages/browser-extensions.scm39
1 files changed, 13 insertions, 26 deletions
diff --git a/gnu/packages/browser-extensions.scm b/gnu/packages/browser-extensions.scm
index 9cd0cf9b9e..b643f40843 100644
--- a/gnu/packages/browser-extensions.scm
+++ b/gnu/packages/browser-extensions.scm
@@ -48,30 +48,19 @@ supported content to the Kodi media center.")
(define-public play-to-kodi/chromium
(make-chromium-extension play-to-kodi))
-(define uassets
- (let ((commit "54e217d9051831d0d8856286a877962e0f592d45"))
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/uBlockOrigin/uAssets")
- (commit commit)))
- (file-name (git-file-name "uAssets" (string-take commit 9)))
- (sha256
- (base32
- "1xhxadm6qyph6kkq3gxg1rar1psb586mniwp7bkyj5zpzzj31wmj")))))
-
(define ublock-origin
(package
(name "ublock-origin")
- (version "1.37.2")
+ (version "1.38.4")
(home-page "https://github.com/gorhill/uBlock")
(source (origin
(method git-fetch)
- (uri (git-reference (url home-page) (commit version)))
+ (uri (git-reference (url home-page) (commit version)
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
(base32
- "1c1dh9kkimvahs9yw1hv67290h8xvmbl10film7g1wamdxydj97y"))))
+ "127b5mg54zfci86q66fss701y20b0mjpa4flx7iar7nviqg9fa1h"))))
(build-system gnu-build-system)
(outputs '("xpi" "firefox" "chromium"))
(arguments
@@ -81,18 +70,18 @@ supported content to the Kodi media center.")
(modify-phases (map (lambda (phase)
(assq phase %standard-phases))
'(set-paths unpack patch-source-shebangs))
- (add-after 'unpack 'link-uassets
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (symlink (string-append (assoc-ref (or native-inputs inputs)
- "uassets"))
- "../uAssets")
- #t))
+ (add-after 'unpack 'do-not-depend-on-git
+ (lambda _
+ ;; The script attempts to checkout the uAssets submodule,
+ ;; but we already did so with git-fetch.
+ (substitute* "tools/make-assets.sh"
+ (("^git submodule update.*")
+ ""))))
(add-after 'unpack 'make-files-writable
(lambda _
;; The build system copies some files and later tries
;; modifying them.
- (for-each make-file-writable (find-files "."))
- #t))
+ (for-each make-file-writable (find-files "."))))
(add-after 'patch-source-shebangs 'build-xpi
(lambda _
(invoke "./tools/make-firefox.sh" "all")))
@@ -107,11 +96,9 @@ supported content to the Kodi media center.")
(install-file "dist/build/uBlock0.firefox.xpi"
(string-append xpi "/lib/mozilla/extensions"))
(copy-recursively "dist/build/uBlock0.firefox" firefox)
- (copy-recursively "dist/build/uBlock0.chromium" chromium)
- #t))))))
+ (copy-recursively "dist/build/uBlock0.chromium" chromium)))))))
(native-inputs
`(("python" ,python-wrapper)
- ("uassets" ,uassets)
("zip" ,zip)))
(synopsis "Block unwanted content from web sites")
(description