summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-27 09:38:11 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-27 20:55:42 +0100
commit827d28914a16ef2d10ebdad4695efdb02ace07fb (patch)
tree4faadb70157f912154874f079ada31399b56a60e /gnu/packages/bootstrap.scm
parentaaf4cb20adbb20b6c7ea9e421f89d0b7acba961a (diff)
downloadguix-patches-827d28914a16ef2d10ebdad4695efdb02ace07fb.tar
guix-patches-827d28914a16ef2d10ebdad4695efdb02ace07fb.tar.gz
gnu: Add cross tool chain.
* gnu/packages/cross-base.scm: New file. * gnu/packages/patches/gcc-cross-environment-variables.patch: New file. * Makefile.am (MODULES): Add cross-base.scm. (dist_patch_DATA): Add gcc-cross-environment-variables.patch. * gnu/packages/base.scm (gcc-4.7): Use `LDFLAGS_FOR_TARGET' instead of `LDFLAGS_FOR_BUILD', and use `-B' instead of `-L'. * gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add case for "mips64el-linux".
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 22ee98879a..809eb84295 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -134,6 +134,7 @@ check whether everything is alright."
"Return the name of Glibc's dynamic linker for SYSTEM."
(cond ((string=? system "x86_64-linux") "/lib/ld-linux-x86-64.so.2")
((string=? system "i686-linux") "/lib/ld-linux.so.2")
+ ((string=? system "mips64el-linux") "/lib/ld.so.1")
(else (error "dynamic linker name not known for this system"
system))))