summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-07-10 14:12:02 +0100
committerPierre Langlois <pierre.langlois@gmx.com>2021-08-02 13:23:32 +0100
commiteb46c6c5c81695af475f7e1e416d05e51157fe60 (patch)
tree05039218f033860dc16dc92b6765a603abae7240 /gnu/packages/bootloaders.scm
parent536bec1ce5b3d68a6773f31e3788c63e8905ce98 (diff)
downloadguix-patches-eb46c6c5c81695af475f7e1e416d05e51157fe60.tar
guix-patches-eb46c6c5c81695af475f7e1e416d05e51157fe60.tar.gz
gnu: u-boot: Update to 2021.07.
* gnu/packages/patches/u-boot-sifive-prevent-reloc-initrd-fdt.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (%u-boot-sifive-prevent-relocating-initrd-fdt): New variable. (u-boot): Update to 2021.07. [native-inputs]: Add python-pycryptodomex. (u-boot-2021.07): Delete variable. (u-boot-tools)[arguments]: Adapt 'patch phase, disable failing test_spl test. (u-boot-sifive-unmatched): Use default u-boot package. (u-boot-pinebook-pro-rk3328): Use default u-boot package.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm47
1 files changed, 19 insertions, 28 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 261184ff24..504b89f122 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-crypto)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages sdl)
@@ -493,20 +494,26 @@ tree binary files. These are board description files used by Linux and BSD.")
;; and https://patchwork.ozlabs.org/project/uboot/patch/20210406151059.1187379-1-icenowy@aosc.io
(search-patch "u-boot-rockchip-inno-usb.patch"))
+(define %u-boot-sifive-prevent-relocating-initrd-fdt
+ ;; Fix boot in 2021.07 on Hifive unmatched, see
+ ;; https://bugs.launchpad.net/ubuntu/+source/u-boot/+bug/1937246
+ (search-patch "u-boot-sifive-prevent-reloc-initrd-fdt.patch"))
+
(define u-boot
(package
(name "u-boot")
- (version "2021.04")
+ (version "2021.07")
(source (origin
(patches
- (list %u-boot-rockchip-inno-usb-patch))
+ (list %u-boot-rockchip-inno-usb-patch
+ %u-boot-sifive-prevent-relocating-initrd-fdt))
(method url-fetch)
(uri (string-append
"https://ftp.denx.de/pub/u-boot/"
"u-boot-" version ".tar.bz2"))
(sha256
(base32
- "06p1vymf0dl6jc2xy5w7p42mpgppa46lmpm2ishmgsycnldqnhqd"))))
+ "0zm7igkdnz0w4ir8rfl2dislfrl0ip104grs5hvd30a5wkm7wari"))))
(native-inputs
`(("bc" ,bc)
("bison" ,bison)
@@ -516,6 +523,7 @@ tree binary files. These are board description files used by Linux and BSD.")
("perl" ,perl)
("python" ,python)
("python-coverage" ,python-coverage)
+ ("python-pycryptodomex" ,python-pycryptodomex)
("python-pytest" ,python-pytest)
("swig" ,swig)))
(build-system gnu-build-system)
@@ -525,21 +533,6 @@ tree binary files. These are board description files used by Linux and BSD.")
also initializes the boards (RAM etc).")
(license license:gpl2+)))
-(define-public u-boot-2021.07
- (package
- (inherit u-boot)
- (version "2021.07-rc4")
- (source (origin
- (patches
- (list %u-boot-rockchip-inno-usb-patch))
- (method url-fetch)
- (uri (string-append
- "https://ftp.denx.de/pub/u-boot/"
- "u-boot-" version ".tar.bz2"))
- (sha256
- (base32
- "0bnsywgy2b0jxim5h9dc807lqk5kq8hvgf4lcsmffnc0hf4isv8p"))))))
-
(define-public u-boot-tools
(package
(inherit u-boot)
@@ -568,9 +561,13 @@ also initializes the boards (RAM etc).")
;; This test would require git.
(("\\./tools/patman/patman") (which "true"))
;; FIXME: test fails, needs further investiation
- (("run_test \"binman\"") ": run_test \"binman\"")
+ (("run_test \"binman\"") "# run_test \"binman\"")
+ ;; FIXME: test_spl fails, needs further investiation
+ (("test_ofplatdata or test_handoff or test_spl")
+ "test_ofplatdata or test_handoff")
;; FIXME: code coverage not working
- (("run_test \"binman code coverage\"") ": run_test \"binman code coverage\"")
+ (("run_test \"binman code coverage\"")
+ "# run_test \"binman code coverage\"")
;; This test would require internet access.
(("\\./tools/buildman/buildman") (which "true")))
(substitute* "test/py/tests/test_sandbox_exit.py"
@@ -879,11 +876,7 @@ to Novena upstream, does not load u-boot.img from the first partition.")
(make-u-boot-package "sifive_fu540" "riscv64-linux-gnu"))
(define-public u-boot-sifive-unmatched
- (let ((base (make-u-boot-package "sifive_unmatched" "riscv64-linux-gnu")))
- (package
- (inherit base)
- (version (package-version u-boot-2021.07))
- (source (package-source u-boot-2021.07)))))
+ (make-u-boot-package "sifive_unmatched" "riscv64-linux-gnu"))
(define-public u-boot-rock64-rk3328
(let ((base (make-u-boot-package "rock64-rk3328" "aarch64-linux-gnu")))
@@ -946,9 +939,7 @@ to Novena upstream, does not load u-boot.img from the first partition.")
(define-public u-boot-pinebook-pro-rk3399
(let ((base (make-u-boot-package "pinebook-pro-rk3399" "aarch64-linux-gnu")))
(package
- (inherit base)
- (version (package-version u-boot-2021.07))
- (source (package-source u-boot-2021.07))
+ (inherit base)
(arguments
(substitute-keyword-arguments (package-arguments base)
((#:phases phases)