summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-11 02:05:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-12 20:58:16 +0200
commit2d115ea7edd4d5d85df18424e1e691935184a8c8 (patch)
treedf3102170150834137112db92be7564761c8a2a2 /gnu/packages/bootloaders.scm
parent154a4e046281c28e39b5016e965d3d937a2ea4a1 (diff)
downloadguix-patches-2d115ea7edd4d5d85df18424e1e691935184a8c8.tar
guix-patches-2d115ea7edd4d5d85df18424e1e691935184a8c8.tar.gz
gnu: grub: Update to 2.06.
[source]: Remove upstreamed patches. * gnu/packages/patches/grub-setup-root.patch: Update patch. * gnu/packages/patches/grub-verifiers-Blocklist-fallout-cleanup.patch, gnu/packages/patches/grub-cross-system-i686.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index ae3752cec3..79ea9ea345 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -88,18 +88,16 @@
(define-public grub
(package
(name "grub")
- (version "2.04")
+ (version "2.06")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/grub/grub-" version ".tar.xz"))
(sha256
(base32
- "0zgp5m3hmc9jh8wpjx6czzkh5id2y8n1k823x2mjvm2sk6b28ag5"))
+ "1qbycnxkx07arj9f2nlsi9kp0dyldspbv07ysdyd34qvz55a97mp"))
(patches (search-patches
"grub-efi-fat-serial-number.patch"
- "grub-setup-root.patch"
- "grub-verifiers-Blocklist-fallout-cleanup.patch"
- "grub-cross-system-i686.patch"))))
+ "grub-setup-root.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags