summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-20 09:12:01 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 09:12:01 +0000
commit650e85d85514c5fae06adf97ae615643a41bbbd8 (patch)
tree4029c3065343c2b971e667f5beba613832c8f3f4 /gnu/packages/bootloaders.scm
parentb452fe87e0c6e7634a2cb44274fa46832c763b40 (diff)
downloadguix-patches-650e85d85514c5fae06adf97ae615643a41bbbd8.tar
guix-patches-650e85d85514c5fae06adf97ae615643a41bbbd8.tar.gz
gnu: grub: Strip debug symbols.
This is a follow-up of 71aa29911cf3f4e6db5f9bff9237308b5f93283d. Grub does not support modules stripped with --strip-unneeded but supports the --strip-debug option. * gnu/packages/bootloaders.scm (grub)[arguments]<#:strip-binaries>: Set to true and use ... <#:strip-flags>: ... to pass --strip-debug instead of --strip-unneeded.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index c0fa16f197..cc23d77cf8 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -114,8 +114,8 @@
;; calling the ‘true’ binary instead. Python is only needed during
;; bootstrapping (for genptl.py), not when building from a release.
(list "PYTHON=true")
- ;; Grub fails to load stripped modules.
- #:strip-binaries? #f
+ ;; Grub fails to load modules stripped with --strip-unneeded.
+ #:strip-flags '("--strip-debug" "--enable-deterministic-archives")
#:phases (modify-phases %standard-phases
(add-after 'unpack 'patch-stuff
(lambda* (#:key native-inputs inputs #:allow-other-keys)