summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-11-24 10:17:28 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-24 10:40:39 +0100
commit097b7255329b9222efb29fe99d9bf71bfae7d1d8 (patch)
tree70b0ffa15669a5efbb9534f0d1e906a60f38ab79 /gnu/packages/bootloaders.scm
parent98f5548cc71fec81728043b78b0668ac2dc1ca7d (diff)
downloadguix-patches-097b7255329b9222efb29fe99d9bf71bfae7d1d8.tar
guix-patches-097b7255329b9222efb29fe99d9bf71bfae7d1d8.tar.gz
gnu: grub-minimal: Fix cross-compilation.
Fixes a regression introduced in 34a6f123514b5677d442ed7cd609ff01534904b8 that would break cross-compilation of 'grub-minimal' because it would enable Freetype support as a side effect but the 'set-freetype-variables' phase was not inherited in 'grub-minimal'. * gnu/packages/bootloaders.scm (grub-minimal)[arguments]: Use 'substitute-keyword-arguments' so that the 'set-freetype-variables' phase is inherited.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm30
1 files changed, 17 insertions, 13 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 2e9709982f..75ae8d919b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -258,21 +258,25 @@ menu to select one of the installed operating systems.")
(fold alist-delete (package-native-inputs grub)
'("help2man" "texinfo" "parted" "qemu" "xorriso")))
(arguments
- `(#:configure-flags (list "PYTHON=true")
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-stuff
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (substitute* "grub-core/Makefile.in"
- (("/bin/sh") (which "sh")))
+ (substitute-keyword-arguments (package-arguments grub)
+ ((#:configure-flags _ ''())
+ '(list "PYTHON=true"))
+ ((#:tests? _ #t)
+ #f)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (replace 'patch-stuff
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (substitute* "grub-core/Makefile.in"
+ (("/bin/sh") (which "sh")))
- ;; Make the font visible.
- (copy-file (assoc-ref (or native-inputs inputs)
- "unifont")
- "unifont.bdf.gz")
- (system* "gunzip" "unifont.bdf.gz")
+ ;; Make the font visible.
+ (copy-file (assoc-ref (or native-inputs inputs)
+ "unifont")
+ "unifont.bdf.gz")
+ (system* "gunzip" "unifont.bdf.gz")
- #t)))
- #:tests? #f))))
+ #t))))))))
(define-public grub-efi
(package