summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-04-26 14:38:23 +0200
committerAndreas Enge <andreas@enge.fr>2015-04-26 14:38:23 +0200
commitf763eaaaf94e048941885c8aa5aaf8d386d542a6 (patch)
tree5459a15c13679a46824c5900545927464eeec5d9 /gnu/packages/boost.scm
parent378b01dc09f50afa32dcb5c77cb6be56bfc419a3 (diff)
downloadguix-patches-f763eaaaf94e048941885c8aa5aaf8d386d542a6.tar
guix-patches-f763eaaaf94e048941885c8aa5aaf8d386d542a6.tar.gz
gnu: Add mdds.
* gnu/packages/boost.scm (mdds): New variable.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 10c88f3f2a..2bdd8f19f0 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -102,3 +102,25 @@
across a broad spectrum of applications.")
(license (license:x11-style "http://www.boost.org/LICENSE_1_0.txt"
"Some components have other similar licences."))))
+
+(define-public mdds
+ (package
+ (name "mdds")
+ (version "0.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://kohei.us/files/mdds/src/mdds_" version ".tar.bz2"))
+ (sha256
+ (base32
+ "10ar7r0gkdl2r7916jlkl5c38cynrh7x9s90a5i8d242r8ixw8ia"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("boost" ,boost))) ; inclusion of header files
+ (home-page "https://code.google.com/p/multidimalgorithm/")
+ (synopsis "Multi-dimensional C++ data structures and indexing algorithms")
+ (description "Mdds (multi-dimensional data structure) provides a
+collection of multi-dimensional data structures and indexing algorithms
+for C++. It includes flat segment trees, segment trees, rectangle sets,
+point quad trees, multi-type vectors and multi-type matrices.")
+ (license license:expat)))