summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-05-10 18:42:02 -0400
committerLeo Famulari <leo@famulari.name>2023-05-22 15:36:50 -0400
commite5f034d83b64a8e8bd878229dd03bc8332353970 (patch)
treeed981648ddff2326a89b6a350349bfd553c51f1f /gnu/packages/bittorrent.scm
parentdff1689bb37e5303868584d3f1d7a33cbcb7f51e (diff)
downloadguix-patches-e5f034d83b64a8e8bd878229dd03bc8332353970.tar
guix-patches-e5f034d83b64a8e8bd878229dd03bc8332353970.tar.gz
gnu: tremc: Fix compatibility with Transmission 4.0.
This version is not released upstream, but it does fix compatibility with Transmission 4.0 and works for me. * gnu/packages/bittorrent.scm: Update to 0.9.3-0.6c15e3f.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 97f5e7708e..38e959b884 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -239,19 +239,21 @@ XML-RPC over SCGI.")
(license l:gpl2+)))
(define-public tremc
+ (let ((commit "6c15e3f5637c8f3641473328bd8c5b0cc122d930")
+ (revision "0"))
(package
(name "tremc")
- (version "0.9.3")
+ (version (git-version "0.9.3" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tremc/tremc")
- (commit version)))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "11izsgwj435skkgvw96an6ddcm1hk3ff1gji4ksnidlyv6g6npyv"))))
+ "1anlqzbwgmhrxlh20pfzf4iyw5l2w227h95rq6xf29ai7vddr82k"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no test suite
@@ -268,7 +270,7 @@ XML-RPC over SCGI.")
(description "Tremc is a console client, with a curses interface, for the
Transmission BitTorrent daemon.")
(home-page "https://github.com/tremc/tremc")
- (license l:gpl3+)))
+ (license l:gpl3+))))
(define-public aria2
(package