summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
commit13bb3d8bead3332d45e88563a8b166e1a24ec3fd (patch)
tree8d780b0ab1f01fdfcdc7d3ced2f7c9538fdd2711 /gnu/packages/bittorrent.scm
parentab8c774191456e814cdb7cd3af66d1053a222a79 (diff)
downloadguix-patches-13bb3d8bead3332d45e88563a8b166e1a24ec3fd.tar
guix-patches-13bb3d8bead3332d45e88563a8b166e1a24ec3fd.tar.gz
gnu: qbittorrent-nox: Rename to qbittorrent-no-x.
* gnu/packages/bittorrent.scm (qbittorrent-no-x): New variable, renamed from… (qbittorrent-nox): …this package, now redefined as a DEPRECATED-PACKAGE.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 374bea3384..9fcaf77474 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -494,11 +494,11 @@ qBittorrent is fast, stable and provides unicode support as well as many
features.")
(license l:gpl2+)))
-(define-public qbittorrent-nox
+(define-public qbittorrent-no-x
(let ((base qbittorrent))
(package
(inherit base)
- (name "qbittorrent-nox")
+ (name "qbittorrent-no-x")
(arguments
(substitute-keyword-arguments (package-arguments base)
((#:configure-flags configure-flags)
@@ -507,6 +507,9 @@ features.")
(modify-inputs (package-inputs base)
(delete "qtsvg-5"))))))
+(define-public qbittorrent-nox
+ (deprecated-package "qbittorrent-nox" qbittorrent-no-x))
+
(define-public qbittorrent-enhanced
(package
(inherit qbittorrent)