summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-26 07:49:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-26 07:49:50 +0200
commit3c5698046a4b4c8934866e0195e899f73163020d (patch)
treec646996d09da3de12cba9ec50acebb64d66d2cc0 /gnu/packages/bittorrent.scm
parentff4dc16eac6c15dfa2bc0ef92ea3b6b9f29d0680 (diff)
downloadguix-patches-3c5698046a4b4c8934866e0195e899f73163020d.tar
guix-patches-3c5698046a4b4c8934866e0195e899f73163020d.tar.gz
gnu: libtorrent-rasterbar: Update to 1.1.2.
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.1.2. [source]: Use patch. * gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 635b94f4a0..a0474002b7 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -31,6 +31,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system glib-or-gtk)
#:use-module ((guix licenses) #:prefix l:)
+ #:use-module (gnu packages)
#:use-module (gnu packages adns)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -379,16 +380,19 @@ and will take advantage of multiple processor cores where possible.")
(define-public libtorrent-rasterbar
(package
(name "libtorrent-rasterbar")
- (version "1.0.10")
+ (version "1.1.2")
(source (origin
(method url-fetch)
(uri
(string-append
"https://github.com/arvidn/libtorrent/releases/download/libtorrent-"
- "1_0_10" "/libtorrent-rasterbar-" version ".tar.gz"))
+ (string-join (string-split version #\.) "_")
+ "/libtorrent-rasterbar-" version ".tar.gz"))
+ (patches
+ (search-patches "libtorrent-rasterbar-boost-compat.patch"))
(sha256
(base32
- "0gjcr892hzmcngvpw5bycjci4dk49v763lsnpvbwsjmim2ncwrd8"))))
+ "16im9qsmfrmmkhfjpij9739nqpn4s6wgc9cikdxbcyshfhimzra5"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags