summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-01 00:35:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:16 +0200
commit53b2fe29734c58c0cf4a5ef0ae51a595998d7fa3 (patch)
treed78c4a56dceaa88f69a3eac76c4604403772ecaf /gnu/packages/bioinformatics.scm
parente9d70b85ebc7088629d6b513da3d48a95e4ec75c (diff)
downloadguix-patches-53b2fe29734c58c0cf4a5ef0ae51a595998d7fa3.tar
guix-patches-53b2fe29734c58c0cf4a5ef0ae51a595998d7fa3.tar.gz
gnu: python-scikit-bio: Update to 0.6.0.
* gnu/packages/patches/python-scikit-bio-1887.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/bioinformatics.scm (python-scikit-bio): Update to 0.6.0. [source]: Remove patch. [arguments]: Disable skbio.diversity doctest; remove 'compatibility phase. [propagated-inputs]: Add python-biom-format; remove python-ipython and python-matplotlib. Change-Id: I9bd9e0fd72f5f1b80ef6ff61c52da5fd56a715ed
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4b6d85dfba..1d796e31a6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5278,25 +5278,24 @@ and record oriented data modeling and the Semantic Web.")
(define-public python-scikit-bio
(package
(name "python-scikit-bio")
- (version "0.5.9")
+ (version "0.6.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "scikit-bio" version))
(sha256
(base32
- "0429060pkyq1pm19zb2n1la7czh7b633mp4a4h01j8zfigf49q3s"))
- (patches (search-patches "python-scikit-bio-1887.patch"))))
+ "03y1n91p6m44hhxm3rpb355j6ddalydz49s94h85kbhm7iy5l40h"))))
(build-system pyproject-build-system)
(arguments
(list
+ #:test-flags
;; Accuracy problem
- #:test-flags '(list "-k" "not test_fisher_alpha")
+ '(list "-k" (string-append "not test_fisher_alpha"
+ ;; UNEXPECTED EXCEPTION: ValueError("could
+ ;; not convert string to float: 'gut'")
+ " and not skbio.diversity"))
#:phases
'(modify-phases %standard-phases
- (add-after 'unpack 'compatibility
- (lambda _
- (substitute* "skbio/diversity/__init__.py"
- ((", numeric_only=True") ""))))
(add-before 'check 'build-extensions
(lambda _
;; Cython extensions have to be built before running the tests.
@@ -5306,11 +5305,10 @@ and record oriented data modeling and the Semantic Web.")
(when tests?
(apply invoke "python3" "-m" "skbio.test" test-flags)))))))
(propagated-inputs
- (list python-decorator
+ (list python-biom-format
+ python-decorator
python-h5py
python-hdmedians
- python-ipython
- python-matplotlib
python-natsort
python-numpy
python-pandas