summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 13:35:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:18 -0400
commitbb35b50adc132c416f1d00c9c632e00327b889bf (patch)
tree5d1294541d59dcb3a0e5de743ea50b93a01914a0 /gnu/packages/bioinformatics.scm
parentbcdd45be6f1e5c5dfc77e1ef365fa0bb420ae74f (diff)
downloadguix-patches-bb35b50adc132c416f1d00c9c632e00327b889bf.tar
guix-patches-bb35b50adc132c416f1d00c9c632e00327b889bf.tar.gz
gnu: Remove poretools.
* gnu/packages/bioinformatics.scm (poretools): Delete variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 727d88ce27..e7c749c453 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12909,42 +12909,6 @@ of Nanopore reads that were barcoded with the Native Barcoding Kit, PCR
Barcoding Kit or Rapid Barcoding Kit.")
(license license:gpl3+))))
-(define-public poretools
- ;; The latest release was in 2016 and the latest commit is from 2017
- ;; the recommended way to install is to clone the git repository
- ;; https://poretools.readthedocs.io/en/latest/content/installation.html
- (let ((commit "e426b1f09e86ac259a00c261c79df91510777407")
- (revision "1"))
- (package
- (name "poretools")
- (version (git-version "0.6.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/arq5x/poretools")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0bglj833wxpp3cq430p1d3xp085ls221js2y90w7ir2x5ay8l7am"))))
- (build-system python-build-system)
- ;; requires python >=2.7, <3.0, and the same for python dependencies
- (arguments `(#:python ,python-2))
- (inputs
- (list hdf5))
- (propagated-inputs
- (list python2-dateutil python2-h5py python2-matplotlib
- python2-pandas python2-seaborn))
- (home-page "https://poretools.readthedocs.io")
- (synopsis "Toolkit for working with nanopore sequencing data")
- (description
- "The MinION from Oxford Nanopore Technologies is a nanopore sequencer.
-This @code{poretools} package is a flexible toolkit for exploring datasets
-generated by nanopore sequencing devices for the purposes of quality control and
-downstream analysis. Poretools operates directly on the native FAST5, a variant
-of the Hierarchical Data Format (HDF5) standard.")
- (license license:expat))))
-
(define-public jamm
(package
(name "jamm")