summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-03 16:55:43 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-03 16:55:43 +0100
commit3f98071ac5d8ffa722b2cf9c74c9c38bf413f059 (patch)
tree494c4af6cfc996d6acd764025bb78f1a1598d5c9 /gnu/packages/bioinformatics.scm
parent0a77fdf4b8732598e341a6793503ea4847e0c760 (diff)
parent2bb12f5a68f6547b3de295c22c2886aaa0415e47 (diff)
downloadguix-patches-3f98071ac5d8ffa722b2cf9c74c9c38bf413f059.tar
guix-patches-3f98071ac5d8ffa722b2cf9c74c9c38bf413f059.tar.gz
Merge branch 'python-tests'
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 15 insertions, 22 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0fc8c0483e..7bf39c6b03 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -499,6 +499,9 @@ provides the Ribotaper pipeline.")
("python-matplotlib" ,python2-matplotlib)
("python-scipy" ,python2-scipy)
("python-statsmodels" ,python2-statsmodels)))
+ (native-inputs
+ `(("python-mock" ,python2-mock)
+ ("python-nose" ,python2-nose)))
(home-page "http://public.bmi.inf.ethz.ch/user/zhongy/RiboDiff/")
(synopsis "Detect translation efficiency changes from ribosome footprints")
(description "RiboDiff is a statistical tool that detects the protein
@@ -604,6 +607,8 @@ Python.")
("python-future" ,python-future)
("python-click" ,python-click)
("python-h5py" ,python-h5py)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
(home-page "http://www.biom-format.org")
(synopsis "Biological Observation Matrix (BIOM) format utilities")
(description
@@ -1602,6 +1607,7 @@ databases.")
("python-scipy" ,python2-scipy)))
(native-inputs
`(("python-mock" ,python2-mock) ; for tests
+ ("python-nose" ,python2-nose) ; for tests
("python-pytz" ,python2-pytz))) ; for tests
(home-page "https://github.com/YeoLab/clipper")
(synopsis "CLIP peak enrichment recognition")
@@ -1978,7 +1984,8 @@ accessing bigWig files.")
(uri (pypi-uri "DendroPy" version))
(sha256
(base32
- "15c7s3d5gf19ljsxvq5advaa752wfi7pwrdjyhzmg85hccyvp47p"))))
+ "15c7s3d5gf19ljsxvq5advaa752wfi7pwrdjyhzmg85hccyvp47p"))
+ (patches (search-patches "python-dendropy-fix-tests.patch"))))
(build-system python-build-system)
(home-page "http://packages.python.org/DendroPy/")
(synopsis "Library for phylogenetics and phylogenetic computing")
@@ -2030,6 +2037,7 @@ trees (phylogenies) and characters.")
("python-pybigwig" ,python2-pybigwig)))
(native-inputs
`(("python-mock" ,python2-mock) ;for tests
+ ("python-nose" ,python2-nose) ;for tests
("python-pytz" ,python2-pytz))) ;for tests
(home-page "https://github.com/fidelram/deepTools")
(synopsis "Tools for normalizing and visualizing deep-sequencing data")
@@ -2969,28 +2977,10 @@ data. It also provides the bgzip, htsfile, and tabix utilities.")
"1k3x44biak00aiv3hpm1yd6nn4hhp7n0qnbs3zh2q9sw7qr1qj5r"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after
- 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (python-version (string-take (string-take-right
- (assoc-ref inputs "python") 5) 3))
- (path (string-join
- (map (lambda (name)
- (string-append (assoc-ref inputs name)
- "/lib/python" python-version
- "/site-packages"))
- '("python-scipy"
- "python-numpy"
- "python-matplotlib"))
- ":")))
- (wrap-program (string-append out "/bin/idr")
- `("PYTHONPATH" ":" prefix (,path))))
- #t)))))
- (inputs
+ `(#:tests? #f)) ; FIXME: "ImportError: No module named 'utility'"
+ (propagated-inputs
`(("python-scipy" ,python-scipy)
+ ("python-sympy" ,python-sympy)
("python-numpy" ,python-numpy)
("python-matplotlib" ,python-matplotlib)))
(native-inputs
@@ -3679,6 +3669,9 @@ the phenotype as it models the data.")
(build-system python-build-system)
(arguments
`(#:python ,python-2
+ ;; FIXME: Tests fail with "No such file or directory:
+ ;; pbtools/pbtranscript/modified_bx_intervals/intersection_unique.so"
+ #:tests? #f
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'enter-directory