summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-16 13:16:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-16 13:16:39 +0100
commit14386fc7d9192b35a81dedb7616a44651807ee19 (patch)
tree15097f536cd155bb0494c986fd14c73572eba80b /gnu/packages/bioinformatics.scm
parentb7a820fc97485a7bdf7703d3b627871d6a6be6c6 (diff)
downloadguix-patches-14386fc7d9192b35a81dedb7616a44651807ee19.tar
guix-patches-14386fc7d9192b35a81dedb7616a44651807ee19.tar.gz
gnu: idr: Remove explicit wrapper. This is now done implicitly.
* gnu/packages/bioinformatics.scm (idr)[arguments]: Remove #:phases.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 1 insertions, 21 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a2191d060b..3fb9bbc35d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2879,27 +2879,7 @@ data. It also provides the bgzip, htsfile, and tabix utilities.")
"1k3x44biak00aiv3hpm1yd6nn4hhp7n0qnbs3zh2q9sw7qr1qj5r"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; FIXME: "ImportError: No module named 'utility'"
- #:phases
- (modify-phases %standard-phases
- (add-after
- 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (python-version (string-take (string-take-right
- (assoc-ref inputs "python") 5) 3))
- (path (string-join
- (map (lambda (name)
- (string-append (assoc-ref inputs name)
- "/lib/python" python-version
- "/site-packages"))
- '("python-scipy"
- "python-numpy"
- "python-matplotlib"))
- ":")))
- (wrap-program (string-append out "/bin/idr")
- `("PYTHONPATH" ":" prefix (,path))))
- #t)))))
+ `(#:tests? #f)) ; FIXME: "ImportError: No module named 'utility'"
(propagated-inputs
`(("python-scipy" ,python-scipy)
("python-sympy" ,python-sympy)