summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 13:35:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:17 -0400
commitbcdd45be6f1e5c5dfc77e1ef365fa0bb420ae74f (patch)
tree39a8af31b24f396e73e87c27804df68765fb3cc5 /gnu/packages/bioinformatics.scm
parentd2c971e67b546fc94771ecae41340822ea67ac0a (diff)
downloadguix-patches-bcdd45be6f1e5c5dfc77e1ef365fa0bb420ae74f.tar
guix-patches-bcdd45be6f1e5c5dfc77e1ef365fa0bb420ae74f.tar.gz
gnu: Remove python2-dendropy.
* gnu/packages/bioinformatics.scm (python2-dendropy): Delete variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm16
1 files changed, 0 insertions, 16 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a4a2f50b39..727d88ce27 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2955,22 +2955,6 @@ writing, simulation, processing and manipulation of phylogenetic
trees (phylogenies) and characters.")
(license license:bsd-3)))
-(define-public python2-dendropy
- (let ((base (package-with-python2 python-dendropy)))
- (package/inherit base
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-test
- (lambda _
- ;; This test fails when the full test suite is run, as documented
- ;; at https://github.com/jeetsukumaran/DendroPy/issues/74
- (substitute* "tests/test_dataio_nexml_reader_tree_list.py"
- (("test_collection_comments_and_annotations")
- "do_not_test_collection_comments_and_annotations"))
- #t)))
- ,@(package-arguments base))))))
-
(define-public python-py2bit
(package
(name "python-py2bit")