summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 13:35:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:16 -0400
commit98c4f97d18ad4cbc57459488e7d7edd0bd9d9a78 (patch)
tree4ec3a925addf6406dcf25c2b06bd528953511a61 /gnu/packages/bioinformatics.scm
parent9f4c958d62829ff56cd2703f82e22eb74b917b10 (diff)
downloadguix-patches-98c4f97d18ad4cbc57459488e7d7edd0bd9d9a78.tar
guix-patches-98c4f97d18ad4cbc57459488e7d7edd0bd9d9a78.tar.gz
gnu: Remove ribodiff.
* gnu/packages/bioinformatics.scm (ribodiff): Delete variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm46
1 files changed, 0 insertions, 46 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2c5ad343f5..32c6b29a68 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -840,52 +840,6 @@ frames} (ORFs) using ribosome profiling (ribo-seq) data. This package
provides the Ribotaper pipeline.")
(license license:gpl3+)))
-(define-public ribodiff
- (package
- (name "ribodiff")
- (version "0.2.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ratschlab/RiboDiff")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0x75nlp7qnmm64jasbi6l21f2cy99r2cjyl6b4hr8zf2bq22drnz"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- ;; This test fails because of the matplotlib plotting backend.
- (add-after 'unpack 'disable-plot-test
- (lambda _
- (substitute* "src/ribodiff/functional_test_te.py"
- (("pl\\.make_plots\\(data, opts\\)") "#"))))
- ;; Generate an installable executable script wrapper.
- (add-after 'unpack 'patch-setup.py
- (lambda _
- (substitute* "setup.py"
- (("^(.*)packages=.*" line prefix)
- (string-append line "\n"
- prefix "scripts=['scripts/TE.py'],\n"))))))))
- (inputs
- (list python2-numpy python2-matplotlib python2-scipy
- python2-statsmodels))
- (native-inputs
- (list python2-mock python2-nose))
- (home-page "https://public.bmi.inf.ethz.ch/user/zhongy/RiboDiff/")
- (synopsis "Detect translation efficiency changes from ribosome footprints")
- (description "RiboDiff is a statistical tool that detects the protein
-translational efficiency change from Ribo-Seq (ribosome footprinting) and
-RNA-Seq data. It uses a generalized linear model to detect genes showing
-difference in translational profile taking mRNA abundance into account. It
-facilitates us to decipher the translational regulation that behave
-independently with transcriptional regulation.")
- (license license:gpl3+)))
-
(define-public bioawk
(package
(name "bioawk")