summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorBen J. Woodcroft <donttrustben near gmail.com>2017-03-10 20:25:00 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-10 20:31:30 +1000
commit79f09fa2394c5de06668406222a655eac39c36f6 (patch)
tree26227903f0410b2fabd93e66271b7c9576a89535 /gnu/packages/bioinformatics.scm
parent5ded35d89d33a58294956c4a6c86cfb2fc7c7924 (diff)
downloadguix-patches-79f09fa2394c5de06668406222a655eac39c36f6.tar
guix-patches-79f09fa2394c5de06668406222a655eac39c36f6.tar.gz
gnu: hmmer: Build reproducibly.
* gnu/packages/patches/hmmer-remove-cpu-specificity.patch: New file. * gnu/packages/bioinformatics.scm (hmmer): Use it.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b6f753ef0a..866900d40b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2839,15 +2839,17 @@ indexing scheme is called a @dfn{Hierarchical Graph FM index} (HGFM).")
(package
(name "hmmer")
(version "3.1b2")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://eddylab.org/software/hmmer"
- (version-prefix version 1) "/"
- version "/hmmer-" version ".tar.gz"))
- (sha256
- (base32
- "0djmgc0pfli0jilfx8hql1axhwhqxqb8rxg2r5rg07aw73sfs5nx"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://eddylab.org/software/hmmer"
+ (version-prefix version 1) "/"
+ version "/hmmer-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0djmgc0pfli0jilfx8hql1axhwhqxqb8rxg2r5rg07aw73sfs5nx"))
+ (patches (search-patches "hmmer-remove-cpu-specificity.patch"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)))
(home-page "http://hmmer.org/")