summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2021-06-06 02:06:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-06 08:33:21 +0200
commitd1e7b50dbf58c59c100f1bf5a7ea735daa3a203f (patch)
tree8c4a3e487c42956837dbeae766c44242c4907f1f /gnu/packages/bioinformatics.scm
parent78469645fd26036c0742abf56d59768b49dc65c4 (diff)
downloadguix-patches-d1e7b50dbf58c59c100f1bf5a7ea735daa3a203f.tar
guix-patches-d1e7b50dbf58c59c100f1bf5a7ea735daa3a203f.tar.gz
gnu: python-cooler: Update to 0.8.11.
* gnu/packages/bioinformatics.scm (python-cooler): Update to 0.8.11. [arguments]: Add build phase "patch-tests"; replace "check" phase. [native-inputs]: Add python-codecov, python-pytest-cov, and python-pytest-flake8. [propagated-inputs]: Add python-six and python-sparse.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm42
1 files changed, 36 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dab097381a..2de8a59d3c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11717,15 +11717,39 @@ fasta subsequences.")
(define-public python-cooler
(package
(name "python-cooler")
- (version "0.8.7")
+ (version "0.8.11")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cooler" version))
(sha256
(base32
- "01g6gqix9ba27sappz6nfyiwabzrlf8i5fn8kwcz8ra356cq9crp"))))
+ "1i96fmpsimj4wrx51rxn8lw2gqxf5a2pvrj5rwdd6ivnm3pmhyrn"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* "tests/test_create.py"
+ (("def test_roundtrip")
+ (string-append "@pytest.mark.skip(reason=\"requires network "
+ "access to genome.ucsc.edu\")\n"
+ "def test_roundtrip")))
+ (substitute* "tests/test_util.py"
+ (("def test_fetch_chromsizes")
+ (string-append "@pytest.mark.skip(reason=\"requires network "
+ "access to genome.ucsc.edu\")\n"
+ "def test_fetch_chromsizes")))
+ ;; This test depends on ipytree, which contains a lot of minified
+ ;; JavaScript.
+ (substitute* "tests/test_fileops.py"
+ (("def test_print_trees")
+ "def _test_print_trees"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-v")))))))
(propagated-inputs
`(("python-asciitree" ,python-asciitree)
("python-biopython" ,python-biopython)
@@ -11741,11 +11765,17 @@ fasta subsequences.")
("python-pysam" ,python-pysam)
("python-pyyaml" ,python-pyyaml)
("python-scipy" ,python-scipy)
- ("python-simplejson" ,python-simplejson)))
+ ("python-simplejson" ,python-simplejson)
+ ("python-six" ,python-six)
+ ("python-sparse" ,python-sparse)))
(native-inputs
- `(("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)))
- (home-page "https://github.com/mirnylab/cooler")
+ `(("python-codecov" ,python-codecov)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-flake8" ,python-pytest-flake8)))
+ ;; Almost all the projects of the Mirnylab are moved under Open2C umbrella
+ (home-page "https://github.com/open2c/cooler")
(synopsis "Sparse binary format for genomic interaction matrices")
(description
"Cooler is a support library for a sparse, compressed, binary persistent