summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-14 18:13:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-14 18:13:34 +0200
commit97149c576762de7fd8e1a6ac8f46c97d3490b360 (patch)
tree971fee6c4be8c3d7a43dbc46bb4509f2b6081213 /gnu/packages/bioinformatics.scm
parentad60a3484c6d3221b78dbc6f173ce27bc3b1f96a (diff)
downloadguix-patches-97149c576762de7fd8e1a6ac8f46c97d3490b360.tar
guix-patches-97149c576762de7fd8e1a6ac8f46c97d3490b360.tar.gz
gnu: Adjust uses of C{,PLUS}_INCLUDE_PATH for GCC 7.
These variables are no longer set in the build environment by default. GCC still respects these search paths and treats them as "system headers" so we can continue to use them, just not expect them to be available. * gnu/packages/mpi.scm (openmpi)[arguments]: Do not attempt to read from C_INCLUDE_PATH, nor CPLUS_INCLUDE_PATH. * gnu/packages/games.scm (kiki)[arguments]: Likewise. * gnu/packages/networking.scm (hcxtools)[arguments]: Likewise. * gnu/packages/synergy.scm (synergy)[arguments]: Likewise. * gnu/packages/bioinformatics.scm (gemma, sailfish)[arguments]: Likewise. * gnu/packages/maths.scm (dune-alugrid)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 92bc532196..0dcbb94666 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3260,9 +3260,7 @@ comment or quality sections.")
(lambda* (#:key inputs #:allow-other-keys)
;; Ensure that Eigen headers can be found
(setenv "CPLUS_INCLUDE_PATH"
- (string-append (getenv "CPLUS_INCLUDE_PATH")
- ":"
- (assoc-ref inputs "eigen")
+ (string-append (assoc-ref inputs "eigen")
"/include/eigen3"))
#t))
(add-before 'build 'bin-mkdir
@@ -11697,9 +11695,7 @@ bytes of memory space, where n is the length of the string.")
;; Ensure that Eigen headers can be found
(setenv "CPLUS_INCLUDE_PATH"
- (string-append (getenv "CPLUS_INCLUDE_PATH")
- ":"
- (assoc-ref inputs "eigen")
+ (string-append (assoc-ref inputs "eigen")
"/include/eigen3"))
#t)))))
(inputs