summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-07-26 11:07:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-07-26 11:08:13 +0200
commit99ca1ae4f852387ea0db16a9143726ff9b5a3f84 (patch)
treee3c5b3057bff8d703b9b52d6e3d55d55f6a57eb0 /gnu/packages/bioinformatics.scm
parentd16694b546e86d8e3b0907e2a82a20790c33e9e5 (diff)
downloadguix-patches-99ca1ae4f852387ea0db16a9143726ff9b5a3f84.tar
guix-patches-99ca1ae4f852387ea0db16a9143726ff9b5a3f84.tar.gz
gnu: Add segemehl.
* gnu/packages/bioinformatics.scm (segemehl): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a90a7fa9d4..91a3c1f185 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9388,6 +9388,54 @@ using nucleotide or amino-acid sequence data.")
;; GPLv3 only
(license license:gpl3)))
+(define-public segemehl
+ (package
+ (name "segemehl")
+ (version "0.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.bioinf.uni-leipzig.de/Software"
+ "/segemehl/downloads/segemehl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0lbzbb7i8zadsn9b99plairhq6s2h1z8qdn6n7djclfis01nycz4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ "all")
+ #:tests? #false ; there are none
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ ;; There is no installation target
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (exes (list "segemehl.x" "haarz.x")))
+ (mkdir-p bin)
+ (for-each (lambda (exe)
+ (install-file exe bin))
+ exes)))))))
+ (inputs
+ `(("htslib" ,htslib)
+ ("ncurses" ,ncurses)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.bioinf.uni-leipzig.de/Software/segemehl")
+ (synopsis "Map short sequencer reads to reference genomes")
+ (description "Segemehl is software to map short sequencer reads to
+reference genomes. Segemehl implements a matching strategy based on enhanced
+suffix arrays (ESA). It accepts fasta and fastq queries (gzip'ed and
+bgzip'ed). In addition to the alignment of reads from standard DNA- and
+RNA-seq protocols, it also allows the mapping of bisulfite converted
+reads (Lister and Cokus) and implements a split read mapping strategy. The
+output of segemehl is a SAM or BAM formatted alignment file.")
+ (license license:gpl3+)))
+
(define-public kallisto
(package
(name "kallisto")