summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-12 12:35:14 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-17 12:29:51 +0100
commit9a8336d87b0bd343da9f51ca3964f359a26fbf72 (patch)
treec116094ad2b0cead14fa367f810204e234b61260 /gnu/packages/bioinformatics.scm
parent5762f3062cc62855743c52b11a0de7cd54528981 (diff)
downloadguix-patches-9a8336d87b0bd343da9f51ca3964f359a26fbf72.tar
guix-patches-9a8336d87b0bd343da9f51ca3964f359a26fbf72.tar.gz
gnu: Add bwa.
* gnu/packages/bioinformatics.scm (bwa): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d3b891996d..2e786b3290 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -238,6 +238,53 @@ gapped, local, and paired-end alignment modes.")
(supported-systems '("x86_64-linux"))
(license license:gpl3+)))
+(define-public bwa
+ (package
+ (name "bwa")
+ (version "0.7.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/bio-bwa/bwa-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1330dpqncv0px3pbhjzz1gwgg39kkcv2r9qp2xs0sixf8z8wl7bh"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;no "check" target
+ #:phases
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append
+ (assoc-ref outputs "out") "/bin"))
+ (doc (string-append
+ (assoc-ref outputs "out") "/share/doc/bwa"))
+ (man (string-append
+ (assoc-ref outputs "out") "/share/man/man1")))
+ (mkdir-p bin)
+ (mkdir-p doc)
+ (mkdir-p man)
+ (copy-file "bwa" (string-append bin "/bwa"))
+ (copy-file "README.md" (string-append doc "/README.md"))
+ (copy-file "bwa.1" (string-append man "/bwa.1"))))
+ ;; no "configure" script
+ (alist-delete 'configure %standard-phases))))
+ (inputs `(("zlib" ,zlib)))
+ (home-page "http://bio-bwa.sourceforge.net/")
+ (synopsis "Burrows-Wheeler sequence aligner")
+ (description
+ "BWA is a software package for mapping low-divergent sequences against a
+large reference genome, such as the human genome. It consists of three
+algorithms: BWA-backtrack, BWA-SW and BWA-MEM. The first algorithm is
+designed for Illumina sequence reads up to 100bp, while the rest two for
+longer sequences ranged from 70bp to 1Mbp. BWA-MEM and BWA-SW share similar
+features such as long-read support and split alignment, but BWA-MEM, which is
+the latest, is generally recommended for high-quality queries as it is faster
+and more accurate. BWA-MEM also has better performance than BWA-backtrack for
+70-100bp Illumina reads.")
+ (license license:gpl3+)))
+
(define-public clipper
(package
(name "clipper")