summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-23 23:39:47 +0100
committerMarius Bakke <marius@gnu.org>2020-11-23 23:39:47 +0100
commit87a027243fa5e8b00fa6257847fde5d5af04bce6 (patch)
tree87f85b3d5d9f521e29a09d6c36a4f951a426eab0 /gnu/packages/bioinformatics.scm
parenta485a98ca8296d760251e9d870583117ac50979e (diff)
parent689d88451e7f1db62df5989ac3ff82f540424061 (diff)
downloadguix-patches-87a027243fa5e8b00fa6257847fde5d5af04bce6.tar
guix-patches-87a027243fa5e8b00fa6257847fde5d5af04bce6.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm132
1 files changed, 131 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 01c45fcc96..b051389ae2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2015, 2016 Pjotr Prins <pjotr.guix@thebird.nl>
+;;; Copyright © 2015, 2016, 2018, 2019, 2020 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
@@ -18,6 +18,7 @@
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2020 Bonface Munyoki Kilyungi <bonfacemunyoki@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -102,6 +103,7 @@
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages node)
#:use-module (gnu packages ocaml)
#:use-module (gnu packages pcre)
#:use-module (gnu packages parallel)
@@ -112,10 +114,12 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-compression)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
#:use-module (gnu packages serialization)
@@ -2579,6 +2583,132 @@ accessing bigWig files.")
(define-public python2-pybigwig
(package-with-python2 python-pybigwig))
+(define-public python-schema-salad
+ (package
+ (name "python-schema-salad")
+ (version "7.0.20200811075006")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "schema-salad" version))
+ (sha256
+ (base32
+ "0wanbwmqb189x1m0vacnhpivfsr8rwbqknngivzxxs8j46yj80bg"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cachecontrol" ,python-cachecontrol-0.11)
+ ("python-lockfile" ,python-lockfile)
+ ("python-mistune" ,python-mistune)
+ ("python-rdflib" ,python-rdflib)
+ ("python-rdflib-jsonld" ,python-rdflib-jsonld)
+ ("python-requests" ,python-requests)
+ ("python-ruamel.yaml" ,python-ruamel.yaml)
+ ("python-typing-extensions" ,python-typing-extensions)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/common-workflow-language/schema_salad")
+ (synopsis "Schema Annotations for Linked Avro Data (SALAD)")
+ (description
+ "Salad is a schema language for describing JSON or YAML structured linked
+data documents. Salad schema describes rules for preprocessing, structural
+validation, and hyperlink checking for documents described by a Salad schema.
+Salad supports rich data modeling with inheritance, template specialization,
+object identifiers, object references, documentation generation, code
+generation, and transformation to RDF. Salad provides a bridge between document
+and record oriented data modeling and the Semantic Web.")
+ (license license:asl2.0)))
+
+(define-public cwltool
+ (package
+ (name "cwltool")
+ (version "3.0.20201121085451")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/common-workflow-language/cwltool")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1awf99n7aglxc5zszrlrv6jxp355jp45ws7wpsgjlgcdv7advn0w"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'loosen-version-restrictions
+ (lambda _
+ (substitute* "setup.py"
+ (("== 1.5.1") ">=1.5.1") ; prov
+ ((", < 3.5") "")) ; shellescape
+ #t))
+ (add-after 'unpack 'dont-use-git
+ (lambda _
+ (substitute* "gittaggers.py"
+ (("self.git_timestamp_tag\\(\\)")
+ (string-append "time.strftime('.%Y%m%d%H%M%S', time.gmtime(int("
+ (string-drop ,version 4) ")))")))
+ #t))
+ (add-after 'unpack 'modify-tests
+ (lambda _
+ ;; Tries to connect to the internet.
+ (delete-file "tests/test_udocker.py")
+ (delete-file "tests/test_http_input.py")
+ (substitute* "tests/test_load_tool.py"
+ (("def test_load_graph_fragment_from_packed")
+ (string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
+ "def test_load_graph_fragment_from_packed")))
+ (substitute* "tests/test_examples.py"
+ (("def test_env_filtering")
+ (string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
+ "def test_env_filtering")))
+ ;; Tries to use cwl-runners.
+ (substitute* "tests/test_examples.py"
+ (("def test_v1_0_arg_empty_prefix_separate_false")
+ (string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
+ "def test_v1_0_arg_empty_prefix_separate_false")))
+ #t)))))
+ (propagated-inputs
+ `(("python-argcomplete" ,python-argcomplete)
+ ("python-bagit" ,python-bagit)
+ ("python-coloredlogs" ,python-coloredlogs)
+ ("python-mypy-extensions" ,python-mypy-extensions)
+ ("python-prov" ,python-prov)
+ ("python-pydot" ,python-pydot)
+ ("python-psutil" ,python-psutil)
+ ("python-rdflib" ,python-rdflib)
+ ("python-requests" ,python-requests)
+ ("python-ruamel.yaml" ,python-ruamel.yaml)
+ ("python-schema-salad" ,python-schema-salad)
+ ("python-shellescape" ,python-shellescape)
+ ("python-typing-extensions" ,python-typing-extensions)
+ ;; Not listed as needed but still necessary:
+ ("node" ,node)))
+ (native-inputs
+ `(("python-arcp" ,python-arcp)
+ ("python-humanfriendly" ,python-humanfriendly)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-mock" ,python-pytest-mock)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-rdflib-jsonld" ,python-rdflib-jsonld)))
+ (home-page
+ "https://github.com/common-workflow-language/common-workflow-language")
+ (synopsis "Common Workflow Language reference implementation")
+ (description
+ "This is the reference implementation of the @acronym{CWL, Common Workflow
+Language} standards. The CWL open standards are for describing analysis
+workflows and tools in a way that makes them portable and scalable across a
+variety of software and hardware environments, from workstations to cluster,
+cloud, and high performance computing (HPC) environments. CWL is designed to
+meet the needs of data-intensive science, such as Bioinformatics, Medical
+Imaging, Astronomy, Physics, and Chemistry. The @acronym{cwltool, CWL reference
+implementation} is intended to be feature complete and to provide comprehensive
+validation of CWL files as well as provide other tools related to working with
+CWL descriptions.")
+ (license license:asl2.0)))
+
(define-public python-dendropy
(package
(name "python-dendropy")