summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-20 21:31:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-20 23:37:33 +0200
commit8b4102b9038f394749463d002572a730a44b78ef (patch)
tree9cd635305faede60f7ff081a343cb9ff46dcbaf3 /gnu/packages/bioinformatics.scm
parent895cf8278abab83032b1efb9e050134639491624 (diff)
downloadguix-patches-8b4102b9038f394749463d002572a730a44b78ef.tar
guix-patches-8b4102b9038f394749463d002572a730a44b78ef.tar.gz
gnu: clipper: Update to 1.2.1.
* gnu/packages/bioinformatics.scm (clipper): Update to 1.2.1. [source]: Fetch from git. [arguments]: Add fix-typo phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 18 insertions, 12 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bb9bf00499..3f50ce0737 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1707,29 +1707,35 @@ databases.")
(define-public clipper
(package
(name "clipper")
- (version "1.1")
+ (version "1.2.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/YeoLab/clipper/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/YeoLab/clipper.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0pflmsvhbf8izbgwhbhj1i7349sw1f55qpqj8ljmapp16hb0p0qi"))
+ "0fja1rj84wp9vpj8rxpj3n8zqzcqq454m904yp9as1w4phccirjb"))
(modules '((guix build utils)))
(snippet
'(begin
;; remove unnecessary setup dependency
(substitute* "setup.py"
(("setup_requires = .*") ""))
- (for-each delete-file
- '("clipper/src/peaks.so"
- "clipper/src/readsToWiggle.so"))
- (delete-file-recursively "dist/")
#t))))
(build-system python-build-system)
- (arguments `(#:python ,python-2)) ; only Python 2 is supported
+ (arguments
+ `(#:python ,python-2 ; only Python 2 is supported
+ #:phases
+ (modify-phases %standard-phases
+ ;; This is fixed in upstream commit
+ ;; f6c2990198f906bf97730d95695b4bd5a6d01ddb.
+ (add-after 'unpack 'fix-typo
+ (lambda _
+ (substitute* "clipper/src/readsToWiggle.pyx"
+ (("^sc.*") ""))
+ #t)))))
(inputs
`(("htseq" ,python2-htseq)
("python-pybedtools" ,python2-pybedtools)