summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-07 16:49:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-07 16:50:33 +0200
commitbe067c908c90b9d9f798fdf36f744f72c884f3bd (patch)
tree04cea9f866eb50d7ed5d16f6cd75c901f3770007 /gnu/packages/bioinformatics.scm
parentbb38287570f3a6a4d09d04edb02668a2ab884ec0 (diff)
downloadguix-patches-be067c908c90b9d9f798fdf36f744f72c884f3bd.tar
guix-patches-be067c908c90b9d9f798fdf36f744f72c884f3bd.tar.gz
gnu: pigx-rnaseq: Adjust to upgrade of salmon.
* gnu/packages/bioinformatics.scm (pigx-rnaseq)[arguments]: Add phase "use-latest-salmon".
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a34b123264..206c193952 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10371,6 +10371,13 @@ once. This package provides tools to perform Drop-seq analyses.")
`(#:parallel-tests? #f ; not supported
#:phases
(modify-phases %standard-phases
+ ;; See https://github.com/BIMSBbioinfo/pigx_rnaseq/issues/96
+ (add-after 'unpack 'use-latest-salmon
+ (lambda _
+ (substitute* "snakefile.py"
+ (("\"sa.bin\"") "\"pos.bin\""))
+ (substitute* "tests/test_salmon/test_salmon_index.sh.in"
+ (("sa.bin") "pos.bin"))))
;; "test.sh" runs STAR, which requires excessive amounts of memory.
(add-after 'unpack 'disable-resource-intensive-test
(lambda _