summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-27 14:28:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-30 18:29:56 +0200
commite85b35070caa41926b52625ef0fa828d6acc8271 (patch)
tree35249804f71a256a0c345f70936d7785af978c75 /gnu/packages/bioinformatics.scm
parentb8926ca6178e19d2add07593390409226383ed7e (diff)
downloadguix-patches-e85b35070caa41926b52625ef0fa828d6acc8271.tar
guix-patches-e85b35070caa41926b52625ef0fa828d6acc8271.tar.gz
gnu: Add python-pybbi.
* gnu/packages/bioinformatics.scm (python-pybbi): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0979a86d8d..5d4b4e1316 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14795,6 +14795,53 @@ instruments, or Pacific Biosciences RSII or Sequel sequencers.")
data from @file{.hic} files. This package provides Python bindings.")
(license license:expat)))
+(define-public python-pybbi
+ (package
+ (name "python-pybbi")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pybbi" version))
+ (sha256
+ (base32
+ "1hvy2f28i2b41l1pq15vciqbj538n0lichp8yr6413jmgg06xdsk"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #false ; tests require network access
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-cc
+ (lambda _ (setenv "CC" "gcc")))
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (copy-recursively "tests" "/tmp/tests")
+ (with-directory-excursion "/tmp/tests"
+ (invoke "python" "-m" "pytest" "-v"))))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python-pkgconfig" ,python-pkgconfig)
+ ("python-pytest" ,python-pytest)))
+ (inputs
+ `(("libpng" ,libpng)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ `(("python-cython" ,python-cython)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/nvictus/pybbi")
+ (synopsis "Python bindings to UCSC Big Binary file library")
+ (description
+ "This package provides Python bindings to the UCSC Big
+Binary (bigWig/bigBed) file library. This provides read-level access to local
+and remote bigWig and bigBed files but no write capabilitites. The main
+feature is fast retrieval of range queries into numpy arrays.")
+ (license license:expat)))
+
(define-public r-ascat
(package
(name "r-ascat")