summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-07-21 11:48:07 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-07-21 13:36:08 +0200
commit73830b5da3f71d4418e07e28544207dad2d0809f (patch)
treee4c8f03a5cbdf4bfa9dbe417e15d942cdbc97622 /gnu/packages/bioinformatics.scm
parented636babfaf335989b169ad3768f510310680ca5 (diff)
downloadguix-patches-73830b5da3f71d4418e07e28544207dad2d0809f.tar
guix-patches-73830b5da3f71d4418e07e28544207dad2d0809f.tar.gz
gnu: Add r-battenberg.
* gnu/packages/bioinformatics.scm (r-battenberg): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fbb777400c..0c8ff2b255 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14689,3 +14689,33 @@ instruments, or Pacific Biosciences RSII or Sequel sequencers.")
Number Analysis of Tumors} R package that can be used to infer tumour purity,
ploidy and allele-specific copy number profiles.")
(license license:gpl3)))
+
+(define-public r-battenberg
+ (package
+ (name "r-battenberg")
+ (version "2.2.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wedge-lab/battenberg.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nmcq4c7y5g8h8lxsq9vadz9bj4qgqn118alip520ny6czaxki4h"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-devtools" ,r-devtools)
+ ("r-readr" ,r-readr)
+ ("r-doparallel" ,r-doparallel)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-gridextra" ,r-gridextra)
+ ("r-gtools" ,r-gtools)
+ ("r-ascat" ,r-ascat)))
+ (home-page "https://github.com/Wedge-lab/battenberg")
+ (synopsis "Subclonal copy number estimation in R")
+ (description "This package contains the Battenberg R package for subclonal
+copy number estimation, as described by
+@url{doi:10.1016/j.cell.2012.04.023,Nik-Zainal et al.}")
+ (license license:gpl3)))