summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2016-12-27 22:11:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-31 22:35:08 +0100
commitd4af25b51bbe9980340d70ae103ec92a284e69ce (patch)
treed8de2c10c2bbafbfe6d987418fb8a2ea054f0090 /gnu/packages/bioinformatics.scm
parentf5c8cf3be7a0a19f00cf541020fc6f37d9be2474 (diff)
downloadguix-patches-d4af25b51bbe9980340d70ae103ec92a284e69ce.tar
guix-patches-d4af25b51bbe9980340d70ae103ec92a284e69ce.tar.gz
gnu: Add r-tximport.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c605c58ea6..f8f6ea1ee7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7800,6 +7800,28 @@ for DNA and protein sequences. This package supports several sequence
kernels, including: gkmSVM, kmer-SVM, mismatch kernel and wildcard kernel.")
(license license:gpl2+)))
+(define-public r-tximport
+ (package
+ (name "r-tximport")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "tximport" version))
+ (sha256
+ (base32
+ "1k5a7dad6zqg936s17f6cmwgqp11x24z9zhxndsgwbscgpyhpcb0"))))
+ (build-system r-build-system)
+ (home-page "http://bioconductor.org/packages/tximport")
+ (synopsis "Import and summarize transcript-level estimates for gene-level analysis")
+ (description
+ "This package provides tools to import transcript-level abundance,
+estimated counts and transcript lengths, and to summarize them into matrices
+for use with downstream gene-level analysis packages. Average transcript
+length, weighted by sample-specific transcript abundance estimates, is
+provided as a matrix which can be used as an offset for different expression
+of gene-level counts.")
+ (license license:gpl2+)))
+
(define-public emboss
(package
(name "emboss")