summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-16 15:56:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-16 15:57:27 +0200
commit4d55432fd02279b205097b54c88e3479daba29f5 (patch)
treef76c0db888d8fca69b5cf7df28d71b76f957d1af /gnu/packages/bioinformatics.scm
parent6f5530b9bc3b3fcf6958ed3854d361f38d095a95 (diff)
downloadguix-patches-4d55432fd02279b205097b54c88e3479daba29f5.tar
guix-patches-4d55432fd02279b205097b54c88e3479daba29f5.tar.gz
gnu: pigx-bsseq: Update to 0.1.2.
* gnu/packages/bioinformatics.scm (pigx-bsseq): Update to 0.1.2. [inputs]: Add r-ggrepel, bwa-meth, methyldackel, multiqc, and samblaster.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4c89aa4ef2..4a984bee60 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13040,7 +13040,7 @@ in an easily configurable manner.")
(define-public pigx-bsseq
(package
(name "pigx-bsseq")
- (version "0.0.10")
+ (version "0.1.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BIMSBbioinfo/pigx_bsseq/"
@@ -13048,10 +13048,13 @@ in an easily configurable manner.")
"/pigx_bsseq-" version ".tar.gz"))
(sha256
(base32
- "0l97wvkq4diq8lcarraj33bby1zzf0w804jwi8mlc5qddp8idwhy"))))
+ "0mpzlay2d5cjpmrcp7knff6rg1c2mqszd638n7lw0mc0cycbp9f8"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(;; TODO: tests currently require 12+GB of RAM. See
+ ;; https://github.com/BIMSBbioinfo/pigx_bsseq/issues/164
+ #:tests? #f
+ #:phases
(modify-phases %standard-phases
(add-before 'check 'set-timezone
;; The readr package is picky about timezones.
@@ -13071,6 +13074,7 @@ in an easily configurable manner.")
("r-annotationhub" ,r-annotationhub)
("r-dt" ,r-dt)
("r-genomation" ,r-genomation)
+ ("r-ggrepel" ,r-ggrepel)
("r-methylkit" ,r-methylkit)
("r-rtracklayer" ,r-rtracklayer)
("r-rmarkdown" ,r-rmarkdown)
@@ -13083,10 +13087,14 @@ in an easily configurable manner.")
("python-pyyaml" ,python-pyyaml)
("snakemake" ,snakemake)
("bismark" ,bismark)
- ("fastqc" ,fastqc)
("bowtie" ,bowtie)
+ ("bwa-meth" ,bwa-meth)
+ ("fastqc" ,fastqc)
+ ("methyldackel" ,methyldackel)
+ ("multiqc" ,multiqc)
("trim-galore" ,trim-galore)
("cutadapt" ,cutadapt)
+ ("samblaster" ,samblaster)
("samtools" ,samtools)))
(home-page "https://bioinformatics.mdc-berlin.de/pigx/")
(synopsis "Bisulfite sequencing pipeline from fastq to methylation reports")