summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-06 14:08:53 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:54 +0200
commit07f2e4993b5b80008273de0bb756659321e74183 (patch)
tree8c8d779d41e09e5b4929bdbf2ee10ce4f32b9431 /gnu/packages/bioinformatics.scm
parente51a3f4a727d8bd74ccef6322a422c7e8a421394 (diff)
downloadguix-patches-07f2e4993b5b80008273de0bb756659321e74183.tar
guix-patches-07f2e4993b5b80008273de0bb756659321e74183.tar.gz
gnu: pigx-chipseq: Remove dependency on pandoc-citeproc.
* gnu/packages/patches/pigx-chipseq-no-citeproc.patch: Add patch. * gnu/local.mk: Register it. * gnu/packages/bioinformatics.scm (pigx-chipseq)[source]: Use it. [native-inputs]: Add automake/autoconf.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ed4470e313..150bbc361f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10567,10 +10567,16 @@ expression report comparing samples in an easily configurable manner.")
"/pigx_chipseq-" version ".tar.gz"))
(sha256
(base32
- "0c6npx35sszycf059w1x1k4k9hq1qqxny0i4p57q1188czr4561h"))))
+ "0c6npx35sszycf059w1x1k4k9hq1qqxny0i4p57q1188czr4561h"))
+ (patches (search-patches "pigx-chipseq-no-citeproc.patch"))))
(build-system gnu-build-system)
- ;; parts of the tests rely on access to the network
- (arguments '(#:tests? #f))
+ (arguments
+ `(#:tests? #f ; parts of the tests rely on access to the network
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ (invoke "autoreconf" "-vif"))))))
(inputs
`(("grep" ,grep)
("coreutils" ,coreutils)
@@ -10621,7 +10627,9 @@ expression report comparing samples in an easily configurable manner.")
("bedtools" ,bedtools)
("kentutils" ,kentutils)))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("python-pytest" ,python-pytest)))
(home-page "https://bioinformatics.mdc-berlin.de/pigx/")
(synopsis "Analysis pipeline for ChIP sequencing experiments")
(description "PiGX ChIPseq is an analysis pipeline for preprocessing, peak