summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-07-20 13:41:22 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-07-21 13:36:08 +0200
commit2b665b8a49063803290fcacaa4a36426384f0b19 (patch)
tree373ff4169d467ca97c26a9c8809f549ae08eaa02 /gnu/packages/bioinformatics.scm
parent086c6800cfeb3db88bcd33badf5a6683ba4ce9db (diff)
downloadguix-patches-2b665b8a49063803290fcacaa4a36426384f0b19.tar
guix-patches-2b665b8a49063803290fcacaa4a36426384f0b19.tar.gz
gnu: Add python-pyvcf.
* gnu/packages/bioinformatics.scm (python-pyvcf): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8aa21c4fd6..6aaee38295 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14600,3 +14600,40 @@ modified nucleotides from nanopore sequencing data. Tombo also provides tools
for the analysis and visualization of raw nanopore signal.")
;; Some parts may be BSD-3-licensed.
(license license:mpl2.0)))
+
+(define-public python-pyvcf
+ (package
+ (name "python-pyvcf")
+ (version "0.6.8")
+ ;; Use git, because the PyPI tarballs lack test data.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jamescasbon/PyVCF.git")
+ ;; Latest release is not tagged.
+ (commit "bfcedb9bad1a14074ac4526ffdb610611e073810")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0c7lsssns3zp8fh2ibllzzra003srg9vbxqzmq6654akbzdb7lrf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-installed-tests
+ ;; Do not install test files.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (delete-file-recursively (string-append
+ (site-packages inputs outputs)
+ "vcf/test"))
+ #t)))))
+ (native-inputs `(("python-cython" ,python-cython)))
+ (propagated-inputs
+ `(("python-pysam" ,python-pysam)
+ ("python-rpy2" ,python-rpy2)))
+ (home-page "https://github.com/jamescasbon/PyVCF")
+ (synopsis "Variant Call Format parser for Python")
+ (description "This package provides a @acronym{VCF,Variant Call Format}
+parser for Python.")
+ (license license:expat)))