summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 12:52:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 15:04:03 +0100
commit2b1e53850f3e9116ef86172fccae89698a3dfda5 (patch)
treea372e817a6471c4a01c8d913840184aee8f142a0 /gnu/packages/bioinformatics.scm
parentdc4b4d4d9593a2368b84568e80cee0289c797271 (diff)
downloadguix-patches-2b1e53850f3e9116ef86172fccae89698a3dfda5.tar
guix-patches-2b1e53850f3e9116ef86172fccae89698a3dfda5.tar.gz
gnu: libsbml: Remove references to %build-inputs.
* gnu/packages/bioinformatics.scm (libsbml)[arguments]: Remove references to %build-inputs by using a gexp.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b804f277d2..6189f4769e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14658,13 +14658,13 @@ The output is in SAM format.")
(arguments
`(#:test-target "test"
#:configure-flags
- (list "-DWITH_CHECK=ON"
- (string-append "-DLIBXML_LIBRARY="
- (assoc-ref %build-inputs "libxml2")
- "/lib/libxml2.so")
- (string-append "-DLIBXML_INCLUDE_DIR="
- (assoc-ref %build-inputs "libxml2")
- "/include/libxml2"))))
+ ,#~(list "-DWITH_CHECK=ON"
+ (string-append "-DLIBXML_LIBRARY="
+ #$(this-package-input "libxml2")
+ "/lib/libxml2.so")
+ (string-append "-DLIBXML_INCLUDE_DIR="
+ #$(this-package-input "libxml2")
+ "/include/libxml2"))))
(propagated-inputs
`(("libxml2" ,libxml2)))
(native-inputs