summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-20 10:42:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-20 10:49:48 +0200
commit27952318a58fe264080c351615cc73d40ed458c0 (patch)
tree1260efdc579862fed1a5145cc267812f33f956c4 /gnu/packages/bioinformatics.scm
parent343a0bb1578d772de7abcdd7045f2c54be3dbc4b (diff)
downloadguix-patches-27952318a58fe264080c351615cc73d40ed458c0.tar
guix-patches-27952318a58fe264080c351615cc73d40ed458c0.tar.gz
gnu: fastp: Update to 0.20.1.
* gnu/packages/bioinformatics.scm (fastp): Update to 0.20.1. [arguments]: Set PREFIX instead of BINDIR.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5785e27a85..426926a37c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4583,7 +4583,7 @@ The main functions of FastQC are:
(define-public fastp
(package
(name "fastp")
- (version "0.14.1")
+ (version "0.20.1")
(source
(origin
(method git-fetch)
@@ -4593,19 +4593,18 @@ The main functions of FastQC are:
(file-name (git-file-name name version))
(sha256
(base32
- "1r6ms5zbf5rps4rgp4z73nczadl00b5rqylw8f684isfz27dp0xh"))))
+ "0ly8mxdvrcy23jwxyppysx3dhb1lwsqhfbgpyvargxhfk6k700x4"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there are none
#:make-flags
- (list (string-append "BINDIR=" (assoc-ref %outputs "out") "/bin"))
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
(delete 'configure)
(add-before 'install 'create-target-dir
(lambda* (#:key outputs #:allow-other-keys)
- (mkdir-p (string-append (assoc-ref outputs "out") "/bin"))
- #t)))))
+ (mkdir-p (string-append (assoc-ref outputs "out") "/bin")))))))
(inputs
`(("zlib" ,zlib)))
(home-page "https://github.com/OpenGene/fastp/")